1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意:给定一个树,首先给出树的结点数,以及非叶子结点数,统计树中每层结点的数目 

题解思路:首先对输入进行建树,由于只需要考虑树所在层数,并不需要知道左右子树等信息,因此使用vector<int>child[105]存储

之后对树进行深搜,初始设根节点深度为1,进行dfs,最后输出保存的结点数组即可

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <cctype>
#include <cstring>
#include <cmath>
#include <set>
#include <sstream>

using namespace std;
//思路:由于结点数不超过100,那么树的层数也最多不超过100,使用num数组存储每层的结点数dfs遍历即可
vector<int>child[105];
int num[105];
int max_depth=-1;

void dfs(int dex,int depth)
{
    max_depth=max(max_depth,depth);        //树最大深度
    if(child[dex].size()==0){                   //叶子结点时当前深度数组结点数加1
        num[depth]++;
        return;
    }
    for(int i=0;i<(int)child[dex].size();i++){
        dfs(child[dex][i],depth+1);            //向下dfs搜索,下一层所在深度加1
    }
}

int main()
{
    int n,m;
    int a,b,k;
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&k);
        for(int j=0;j<k;j++){
            scanf("%d",&b);
            child[a].push_back(b);
        }
    }
    dfs(1,1);            //初始设根节点深度为1
    for(int i=1;i<=max_depth;i++){
        if(i!=1) printf(" ");
        printf("%d",num[i]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值