Maximum Sum UVA - 108

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem. Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array: 0 −2 −7 0 9 2 −6 2 −4 1 −4 1 −1 8 0 −2 is in the lower-left-hand corner: 9 2 −4 1 −1 8 and has the sum of 15.

Input

The input consists of an N × N array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127].

Output

The output is the sum of the maximal sub-rectangle.

Sample Input

4 0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2

Sample Output

15

题意
给你一个n*n的矩阵,求子矩阵的和的最大值。
思路:
因为,矩阵相当于二维数组,但是序列是一维的,因此我们可以把矩阵转换为一维的来算。
也就是说让矩阵的连续几列的合并,就转换为一维的了,再用最大子序列的算法去求最大值就即可
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mapp[105][105];
int main()
{
    int n, t, maxx;
    while (~scanf("%d", &n))
    {
        for (int i = 1; i <= n; ++i)
            for (int j = 1; j <= n; ++j)
            {
                scanf("%d", &mapp[i][j]);
                mapp[i][j] += mapp[i - 1][j]; //加上每一列
            }
        maxx = mapp[1][1];
        //从上往下,从左往右
        for (int i = 1; i <= n; ++i)
            for (int j = i; j <= n; ++j)//j从i开始
            {
                t = 0;
                for (int k = 1; k <= n; ++k)
                {
                    if (t >= 0) 
                    t += mapp[j][k] - mapp[i - 1][k];
                    else 
                        t = mapp[j][k] - mapp[i - 1][k];
                    maxx = max(maxx,t);//求最大子序列·
                }
            }
        printf("%d\n", maxx);
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值