HDU 3371Connect the Cities(最小生成树)

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 18982    Accepted Submission(s): 4609
Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 
Input
The first line contains the number of test cases.Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.To make it easy, the cities are signed from 1 to n.Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 
Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 
Sample Input
   
   
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
    
    
1
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int per[505];
struct money{
	int x,y,z;
}my[25005];
int find(int x){
	int r=x;
    while(per[r]!=r) r=per[r]; 
	int i=x;int j;//路径压缩 
	while(i!=r){
		j=per[i];
		per[i]=r;
		i=j;
	} 
	return r;
}
void join(int r1,int r2){
	int f1=find(r1);
	int f2=find(r2);
	if(f1!=f2) per[f1]=f2;
}
bool cmp(money m1,money m2){
	return m1.z<m2.z;
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m,k;
		bool flag=true;
		int minmoney=0;
		scanf("%d%d%d",&n,&m,&k); 
		for(int i=0;i<m;i++){
			scanf("%d%d%d",&my[i].x,&my[i].y,&my[i].z);
		}
		for(int i=1;i<=n;i++){
			per[i]=i;
		} 
		for(int i=0;i<k;i++){
			int num;scanf("%d",&num);
		    int first;scanf("%d",&first);//输入第一个 以便于合并 
			for(int j=0;j<num-1;j++){
				int l;scanf("%d",&l);
				join(first,l);//合并 
			}
		}
		sort(my,my+m,cmp);
		int l=0;
		for(int i=1;i<=n;i++){
			if(per[i]==i) l++;//判断还有几个独立的子树 
		}
		for(int i=0;i<m;i++){
			if(find(my[i].x)!=find(my[i].y)){
				join(my[i].x,my[i].y);
				minmoney+=my[i].z;
				l--;
			}
			if(l==1){
				flag=true;break;
			} 
		}
		
		
		if(flag==true)	printf("%d\n",minmoney);
		else printf("-1\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值