PAT甲级.1031. Hello World for U (20)

1031. Hello World for U (20)


题目:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

这里写图片描述
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入格式:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出格式:

For each test case, print the input string in the shape of U as specified in the description.

输入样例:

helloworld!

输出样例:

这里写图片描述
PAT链接


题意:

输入一个字符串长的N,将该字符串按U型输出。有n1+n2+n3-2=N

  1. n1 == n3即左侧字符数等于右侧图案数
  2. n2>=n1 即底部图案数不小于两边的图案数
  3. 满足以上条件情况下使n1尽可能大

思路:

  1. 输入得到字符串长度:
    gets(str);
    int len = strlen(str);
  1. 分别计算得到n1,n2,n3
    int H = (len+2)/3-1;    //n1-1
    int bottom = (len+2)/3; //n2(下面还会修正)
    ……
    if(remainder == 1)  bottom++;   //n2修正
    else if(remainder == 2) bottom+=2;  //n2修正
    else ;
  1. 先输出n1和n3,最后输出n2
  2. (也可考虑通过二维数组的方式输出)

代码:

/**
* @tag     PAT_A_1031
* @authors R11happy (xushuai100@126.com)
* @date    2016-8-15 15:42-16:02
* @version 1.0
* @Language C++
* @Ranking  220/3486
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cstring>

int main(int argc, char const *argv[])
{
    char str[100];
    gets(str);
    int len = strlen(str);
    int H = (len+2)/3-1;    //n1-1
    int bottom = (len+2)/3; //n2
    int remainder = (len+2)%3;
    if(remainder == 1)  bottom++;   //n2修正
    else if(remainder == 2) bottom+=2;  //n2修正
    else ;
    int i;
    for(i=0; i<H; i++)
    {
        printf("%c",str[i] );   //打印左侧字符
        for(int j=0; j<(bottom-2); j++)
        {
            printf(" ");
        }
        printf("%c\n",str[len-i-1] );   //打印右侧字符
    }
    //打印底部字符
    for(int k=0; k<bottom; k++,i++ )    
    {
        printf("%c",str[i] );
    }
    printf("\n");
    return 0;
}

收获:

1.gets函数在vs2015不能用,要改成gets_s,不过gets_s在PAT中编译出错
2.数学推导后再输出,其中求n1,n2,n3也可以用如下代码:

int n1 = (N+2) / 3;
int n3 = n1;
int n2 = N+2-n1-n3;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值