poj1106Transmitters【求旋转半圆能覆盖的最多点数】

Language:
Transmitters
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4803 Accepted: 2569

Description

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle. 

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations. 

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter. 

Input

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

Output

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Sample Input

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output

3
4
4

题意:给定一个半圆的圆心坐标和半圆半径半圆可以绕圆心旋转求半圆在旋转过程中能覆盖的最多点;

解题思路:先求出点与圆心距离小于r的点然后利用叉积枚举算出叉积大于零的点数即为半圆能覆盖的点数;

AC代码

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define eps 1e-8
using namespace std;
struct point{
	double x,y;
}A[160],B[160];
double dist(point a,point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double cp(point p1,point p2,point p3){
	return (p2.x-p1.x)*(p3.y-p1.y)-(p2.y-p1.y)*(p3.x-p1.x);
}
int main()
{
	int n,i,j,k;
	double r;
	while(scanf("%lf%lf%lf",&A[0].x,&A[0].y,&r)){
		if(r<0)break;
		scanf("%d",&n);k=0;
		for(i=1;i<=n;++i){
			scanf("%lf%lf",&A[i].x,&A[i].y);
			if(dist(A[i],A[0])-r<eps)B[k++]=A[i];
		}
		int ans=0;
		for(i=0;i<k;++i){
			int cnt=0;
			for(j=0;j<k;++j){
				if(cp(A[0],B[i],B[j])>=0)cnt++;
			}
			ans=max(ans,cnt);
		}
		printf("%d\n",ans);
	}
	return 0;	
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值