hdoj4717The Moving Points【三分】

B - The Moving Points
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There are N points in total. Every point moves in certain direction and certain speed. We want to know at what time that the largest distance between any two points would be minimum. And also, we require you to calculate that minimum distance. We guarantee that no two points will move in exactly same speed and direction.
 

Input

The rst line has a number T (T <= 10) , indicating the number of test cases. 
For each test case, first line has a single number N (N <= 300), which is the number of points. 
For next N lines, each come with four integers X  i, Y  i, VX  i and VY  i (-10  6 <= X  i, Y  i <= 10  6, -10  2 <= VX  i , VY  i <= 10  2), (X  i, Y  i) is the position of the i  th point, and (VX  i , VY  i) is its speed with direction. That is to say, after 1 second, this point will move to (X  i + VX  i , Y  i + VY  i).
 

Output

For test case X, output "Case #X: " first, then output two numbers, rounded to 0.01, as the answer of time and distance.
 

Sample Input

     
     
2 2 0 0 1 0 2 0 -1 0 2 0 0 1 0 2 1 -1 0
 

Sample Output

     
     
Case #1: 1.00 0.00 Case #2: 1.00 1.00

提议给出一些点和他们的速度求使他们任意两点间的距离的最大值最小

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define eps 1e-8
using namespace std;
struct point{
	double x,y,vx,vy;
}A[310];
int n;
double MAX(double a,double b){
	return a>b?a:b;
}
double MIN(double a,double b){
	return a<b?a:b;
}
double dist(point a,point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double distmin(double t){
	double max=0;
	for(int i=0;i<n;++i){
		for(int j=i+1;j<n;++j){
			point a,b;
			a.x=A[i].x+t*A[i].vx;
			a.y=A[i].y+t*A[i].vy;
			b.x=A[j].x+t*A[j].vx;
			b.y=A[j].y+t*A[j].vy;
			max=MAX(max,dist(a,b));
		}
	}
	return max;
}
int main()
{
	int t,i,j,k=1;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(i=0;i<n;++i){
			scanf("%lf%lf%lf%lf",&A[i].x,&A[i].y,&A[i].vx,&A[i].vy);
		}
		int size=100;double left=0,right=10000;
		while(size--){
			double mid=(left+right)/2;
			double mmid=(mid+right)/2;
			if(distmin(mid)<distmin(mmid)){
				right=mmid;
			}
			else {
				left=mid;
			}
		}
		printf("Case #%d: %.2lf %.2lf\n",k++,left,distmin(left));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值