poj1932&&hdoj1317XYZZY【SPFA判环】

Language:
XYZZY
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3594 Accepted: 1039

Description

The prototypical computer adventure game, first designed by Will Crowther on the PDP-10 in the mid-1970s as an attempt at computer-refereed fantasy gaming, and expanded into a puzzle-oriented game by Don Woods at Stanford in 1976. (Woods had been one of the authors of INTERCAL.) Now better known as Adventure or Colossal Cave Adventure, but the TOPS-10 operating system permitted only six-letter filenames in uppercase. See also vadding, Zork, and Infocom. 

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 

Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 
  • the energy value for room i 
  • the number of doorways leaving room i 
  • a list of the rooms that are reachable by the doorways leaving room i

The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

Sample Output

hopeless
hopeless
winnable
winnable

题意:一人从1点拥有100点能量他想走到n点在路上有些点的能量值是正有些点的能量值是负当走到某一点的能量值小于零时失败;问能否走到n点

最大路判正环+两点连通判定

#include<cstdio> 
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int maxn=1100;
int node;
int vis[maxn];
int dist[maxn];
int head[maxn<<4];
bool map[maxn];
bool inqueue[maxn];
struct Node{
	int from,to,next,value;
}A[maxn<<4];
void init(){
	node=0;
	memset(vis,0,sizeof(vis));
	memset(dist,0,sizeof(dist));
	memset(head,-1,sizeof(head));
	memset(inqueue,false,sizeof(inqueue));
}
void add(int s,int t,int c){
	A[node].from=s;
	A[node].to=t;
	A[node].value=c;
	A[node].next=head[s];
	head[s]=node++;
}
void judge(int s){
	map[s]=true;
	for(int k=head[s];k!=-1;k=A[k].next){
		if(!map[A[k].to])
			judge(A[k].to);
	}
}
bool SPFA(int n){
	queue<int>Q;vis[1]++;
	dist[1]=100;Q.push(1);
	while(!Q.empty()){
		int top=Q.front();Q.pop();
		inqueue[top]=false;
		for(int k=head[top];k!=-1;k=A[k].next){
			if((dist[A[k].to]<dist[top]+A[k].value)&&(dist[top]+A[k].value)>0){
				dist[A[k].to]=dist[top]+A[k].value;
				if(!inqueue[A[k].to]){
					inqueue[A[k].to]=true;
					vis[A[k].to]++;
					if(vis[A[k].to]>n){
						memset(map,false,sizeof(map));
						judge(A[k].to);
						if(map[n])return true;
					}
					else{
						Q.push(A[k].to);
					}
				}
			}
		}
	}
	return dist[n]>0;
}
int main()
{
	int i,j,k,n,m;
	while(~scanf("%d",&n)&&n>=0){
		int a,b,c;init();
		for(i=1;i<=n;++i){
			scanf("%d%d",&c,&k);
			while(k--){
				scanf("%d",&a);
				add(i,a,c);
			}
		}
		if(SPFA(n)){
			printf("winnable\n");
		}
		else {
			printf("hopeless\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值