hdoj5600N bulbs

 

N bulbs

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 287    Accepted Submission(s): 162


Problem Description
N bulbs are in a row from left to right,some are on, and some are off.The first bulb is the most left one. And the last one is the most right one.they are numbered from 1 to n,from left to right.

in order to save electricity, you should turn off all the lights, but you're lazy.
coincidentally,a passing bear children paper(bear children paper means the naughty boy), who want to pass here from the first light bulb to the last one and leave.

he starts from the first light and just can get to the adjacent one at one step.
But after all,the bear children paper is just a bear children paper. after leaving a light bulb to the next one, he must touch the switch, which will change the status of the light.

your task is answer whether it's possible or not to finishing turning off all the lights, and make bear children paper also reach the last light bulb and then leave at the same time.
 

Input
The first line of the input file contains an integer T, which indicates the number of test cases.

For each test case, there are 2 lines.

The first line of each test case contains 1 integers n.

In the following line contains a 01 sequence, 0 means off and 1 means on.

1T10
1N1000000
 

Output
There should be exactly T lines in the output file.

The i-th line should only contain "YES" or "NO" to answer if it's possible to finish.
 

Sample Input
      
      
1 5 1 0 0 0 0
 

Sample Output
      
      
YES
Hint
Child's path is: 123234545 all switchs are touched twice except the first one.
 

Source
 

我们注意到总的操作次数是跟nnn奇偶的。这个很重要,也就是如果111的数量和nnn不同奇偶,那么一定无解。

那么现在问题是111nnn同奇偶的情况下,是不是一定有解?答案是显然的。

因为111nnn同奇偶,所以000的个数是偶数,我们发现当我们从111走到iii时,假设我们往回走到左边某个点kkk,再走回来iii,那么你会发现有且仅有kkkiii这两个数被设成没有操作。

也就是说我们可以每次任意选择两个点设成没有操作,然而不需操作的点数是偶数个,所以刚好可以满足。

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int main()
{
    int t,i,j,k,n,m,ans;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);ans=0;
        for(i=0;i<n;++i){
            scanf("%d",&k);
            if(k)ans++;
        }
        if(((ans&1)&&(n&1))||((ans%2==0&&n%2==0))){
            printf("YES\n");
        }
        else {
            printf("NO\n");
        }
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值