poj1275Cashier Employment【差分约束】

Language:
Cashier Employment
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7476 Accepted: 2816

Description

A supermarket in Tehran is open 24 hours a day every day and needs a number of cashiers to fit its need. The supermarket manager has hired you to help him, solve his problem. The problem is that the supermarket needs different number of cashiers at different times of each day (for example, a few cashiers after midnight, and many in the afternoon) to provide good service to its customers, and he wants to hire the least number of cashiers for this job. 

The manager has provided you with the least number of cashiers needed for every one-hour slot of the day. This data is given as R(0), R(1), ..., R(23): R(0) represents the least number of cashiers needed from midnight to 1:00 A.M., R(1) shows this number for duration of 1:00 A.M. to 2:00 A.M., and so on. Note that these numbers are the same every day. There are N qualified applicants for this job. Each applicant i works non-stop once each 24 hours in a shift of exactly 8 hours starting from a specified hour, say ti (0 <= ti <= 23), exactly from the start of the hour mentioned. That is, if the ith applicant is hired, he/she will work starting from ti o'clock sharp for 8 hours. Cashiers do not replace one another and work exactly as scheduled, and there are enough cash registers and counters for those who are hired. 

You are to write a program to read the R(i) 's for i=0..23 and ti 's for i=1..N that are all, non-negative integer numbers and compute the least number of cashiers needed to be employed to meet the mentioned constraints. Note that there can be more cashiers than the least number needed for a specific slot. 

Input

The first line of input is the number of test cases for this problem (at most 20). Each test case starts with 24 integer numbers representing the R(0), R(1), ..., R(23) in one line (R(i) can be at most 1000). Then there is N, number of applicants in another line (0 <= N <= 1000), after which come N lines each containing one ti (0 <= ti <= 23). There are no blank lines between test cases.

Output

For each test case, the output should be written in one line, which is the least number of cashiers needed. 
If there is no solution for the test case, you should write No Solution for that case. 

Sample Input

1
1 0 1 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1
5
0
23
22
1
10

Sample Output

1

Source


题意:一个超市在一天中不同时间需要分别需要一定人数的人给出超市在一天中每个时刻所需要的人数和一些人开始能够开始工作的时间开始工作需连续工作八个小时求超市最少需要招多少人。

设:S[i]前i个小时需要的人数和r[i]为第i小时需要的人数need[i]为第i小时开始工作的人数则有此可列关系式

0<=s[i]-s[i-1]<=need[i]

s[i]-s[i-8]>=r[i];

s[24]-(s[i+16]-s[i])>=r[i];

可从小到大枚举所需要的人数判断即可

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
struct Node{
	int from,to,value;
	int next;
}A[110];
bool vis[25];
int r[25],need[25];
int cnt[25],dist[25];
int head[30],node;
void init(){
	node=0;
	memset(cnt,0,sizeof(cnt));
	memset(vis,false,sizeof(vis));
	memset(head,-1,sizeof(head));
	memset(dist,0x3f,sizeof(dist));
}
void add(int u,int v,int c){
	A[node].from=u;
	A[node].to=v;
	A[node].value=c;
	A[node].next=head[u];
	head[u]=node++;
}
bool spfa(){
	int i,j,k,u=0;
	queue<int>Q;
	dist[u]=0;vis[u]=true;
	Q.push(u);
	while(!Q.empty()){
		int u=Q.front();Q.pop();vis[u]=false;
		for(k=head[u];k!=-1;k=A[k].next){
			int v=A[k].to;
			if(dist[v]>dist[u]+A[k].value){
				dist[v]=dist[u]+A[k].value;
				if(!vis[v]){
					cnt[v]++;
					if(cnt[v]>24)return false;
					vis[v]=true;
					Q.push(v);
				}
			}
		}
	}
	return true;
}
int main()
{
	int t,i,j,n,p;
	scanf("%d",&t);
	while(t--){
		for(i=1;i<=24;++i){
			scanf("%d",&r[i]);
		}
		scanf("%d",&n);
		memset(need,0,sizeof(need));
		for(i=0;i<n;++i){
			scanf("%d",&p);
			need[p+1]++;
		}
		int ans=-1;
		for(i=0;i<=n;++i){
			init();
			for(j=1;j<=24;++j){
				add(j,j-1,0);
				add(j-1,j,need[j]);
				if(j>=8&&j<=24){
					add(j,j-8,-r[j]);
				}
				else {
					add(j,j+16,i-r[j]);
				}
			}
			add(24,0,-i);
			if(spfa()){
				ans=i;break;
			}
		}
		if(ans==-1){
			printf("No Solution\n");
		}
		else{
			printf("%d\n",ans);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值