hdoj4908BestCoder Sequence

5 篇文章 0 订阅

BestCoder Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1546    Accepted Submission(s): 529


Problem Description
Mr Potato is a coder.
Mr Potato is the BestCoder.

One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as  Bestcoder Sequence.

As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are  bestcoder sequences in a given permutation of 1 ~ N.
 

Input
Input contains multiple test cases. 
For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.

[Technical Specification]
1. 1 <= N <= 40000
2. 1 <= M <= N
 

Output
For each case, you should output the number of consecutive sub-sequences which are the  Bestcoder Sequences
 

Sample Input
  
  
1 1 1 5 3 4 5 3 2 1
 

Sample Output
  
  
1 3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
#include<vector>
using namespace std;
const int maxn=40010;
int num[maxn];
int vis[maxn];
int visa[maxn];
int visb[maxn];
int main()
{
    int n,m,i,j,k,pos;
    while(scanf("%d%d",&n,&m)!=EOF){
        for(i=1;i<=n;++i){
            scanf("%d",&num[i]);
            if(num[i]==m)pos=i;
        }
        memset(vis,0,sizeof(vis));
        memset(visa,0,sizeof(visa));
        memset(visb,0,sizeof(visb));
        int ans=1;
        for(i=pos-1;i>=1;--i){
            vis[i]=vis[i+1];
            if(num[i]>m)vis[i]++;
            if(((pos-i+1)&1)&&(vis[i]==(pos-i)/2))ans++;
            int g=vis[i],s=(pos-i)-vis[i];
            if(g-s>=0)visa[g-s]++;
            else visb[s-g]++;
        }
        for(i=pos+1;i<=n;++i){
            vis[i]=vis[i-1];
            if(num[i]>m)vis[i]++;
            if(((i-pos+1)&1)&&(vis[i]==(i-pos)/2))ans++;
            int g=vis[i],s=(i-pos)-vis[i];
            if(s-g>=0)ans+=visa[s-g];
            else ans+=visb[g-s];
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值