hdoj5676ztr loves lucky numbers

72 篇文章 0 订阅
46 篇文章 0 订阅

ztr loves lucky numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 487    Accepted Submission(s): 199


Problem Description
ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it's decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.
 

Input
There are T (1n105)  cases

For each cases:

The only line contains a positive integer  n(1n1018) . This number doesn't have leading zeroes.
 

Output
For each cases
Output the answer
 

Sample Input
  
  
2 4500 47
 

Sample Output
  
  
4747 47

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<queue>
#include<list>
#include<vector>
#include<cmath>
using namespace std;
const int maxn=1000010;
long long ans[maxn],cnt=0;
void dfs(long long num,int cnt4,int cnt7,int n){
	if(cnt4>n/2||cnt7>n/2)return;
	if(cnt4+cnt7==n&&cnt4==cnt7){ans[cnt++]=num;return;}
	if(cnt4<=n/2)dfs(num*10+4,cnt4+1,cnt7,n);
	if(cnt7<=n/2)dfs(num*10+7,cnt4,cnt7+1,n);
}
int main()
{
	cnt=0;
	for(long long i=2;i<=18;i+=2){
		dfs(0,0,0,i);
	}
	int t;
	long long n;
	scanf("%d",&t);
	while(t--){
		scanf("%lld",&n);
		if(n>777777777444444444ll){
			printf("44444444447777777777\n");
		}
		else printf("%lld\n",ans[lower_bound(ans,ans+cnt,n)-ans]);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值