hdoj5305【dfs】

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2078    Accepted Submission(s): 1027


Problem Description
There are  n  people and  m  pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these  n  people wants to have the same number of online and offline friends (i.e. If one person has  x  onine friends, he or she must have  x  offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer  T (T=100) , indicating the number of testcases. 

For each testcase, the first line contains two integers  n (1n8)  and  m (0mn(n1)2) , indicating the number of people and the number of pairs of friends, respectively. Each of the next  m  lines contains two numbers  x  and  y , which mean  x  and  y  are friends. It is guaranteed that  xy  and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
  
  
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
  
  
0 2
 

Author
XJZX
 

Source
 


题意:n个人m对朋友关系,每个人可以选择他的朋友为网络朋友或现实朋友且这两种朋友的个数必须相等,问有多少种方法满足条件。

解题思路:按照所给的朋友关系要么这对关系为网路朋友要么为现实朋友dfs即可

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
#include<vector>
using namespace std;
const int maxn=100;
int n,m;
long long ans=0;
struct Node{
	int a,b;
}A[70];
int ol[maxn],of[maxn],vis[10];;
bool judge(){
	for(int i=1;i<=m;++i){
		if(of[A[i].a]!=ol[A[i].a]||of[A[i].b]!=ol[A[i].b])return false;
	}
	return true;
}
void dfs(int k){
	if(k==m+1){
		//if(judge())
		ans++;
		return ;
	}
	ol[A[k].a]++;ol[A[k].b]++;
	if(ol[A[k].a]<=vis[A[k].a]/2&&ol[A[k].b]<=vis[A[k].b]/2)dfs(k+1);
	ol[A[k].a]--;ol[A[k].b]--;
	of[A[k].a]++;of[A[k].b]++;
	if(of[A[k].a]<=vis[A[k].a]/2&&of[A[k].b]<=vis[A[k].b]/2)dfs(k+1);
	of[A[k].a]--;of[A[k].b]--;
}

int main()
{
	int t,i,j,k;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		memset(ol,0,sizeof(ol));
		memset(of,0,sizeof(of));
		memset(vis,0,sizeof(vis));
		for(i=1;i<=m;++i){
			scanf("%d%d",&A[i].a,&A[i].b);
			vis[A[i].a]++;vis[A[i].b]++;
		}
		for(i=1;i<=n;++i){
			if(vis[i]&1)break;
		}
		if(i<=n){
			printf("0\n");
			continue;
		}
		ans=0;dfs(1);
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值