PAT A1077. Kuchiguse (20)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write “nai”.

Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:
nyan~

Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:
nai

没啥可说的,不要怂就是干

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=300;
int main(){
    int N;
    scanf("%d",&N);
    getchar();
    char line[110][maxn];
    int len[110]={0};
    int min,j,k;
    for(int i=0;i<N;i++){
        gets(line[i]);//考查点
        len[i]=strlen(line[i]);
        if(i==0)
            min=len[0];
        else{
            if(len[i]<min)
                min=len[i];//选出最短串长 
        }
    }
    for(k=0;k<min;k++){
        for(j=0;j<N-1;j++){
            if(line[j][len[j]-k-1]!=line[j+1][len[j+1]-k-1]){
                break;//每串倒数第k个字符进行逐次比较 
            }
        }
        if(j<N-1){
            break;//内层for被破出循环后再破出外层循环 
        }
    }
    if(k==0)
        cout<<"nai";
    else{
        for(int i=len[0]-k;i<len[0];i++){
            cout<<line[0][i];
        }
    }

    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值