PAT A1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:
3
4 3 1

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=10010;

int N;
int parent[maxn];
int member[maxn];
int getParent(int a){
    while(parent[a]!=a)
        a=parent[a];
    return a;
}

//在对成员进行合并时也完成了成员个数的移交 
void unions(int a,int b){
    int A=getParent(a);
    int B=getParent(b); 
    if(A!=B){
        if(A<B) {
            parent[B]=A;
            member[A]+=member[B];
            member[B]=0;
        }
        else{
            parent[A]=B;
            member[B]+=member[A];
            member[A]=0;
        }       
    }
}

bool cmp(int a,int b){
    return a>b;
}

int main(void){
    freopen("in.txt","r",stdin);
    fill(member,member+maxn,0);
    cin>>N;
    for(int i=1;i<maxn;++i){
        parent[i]=i;
    }
    int n,a,b;
    for(int i=0;i<N;++i){
        scanf("%d:",&n);
        cin>>a;
        for(int j=1;j<n;++j){
            cin>>b;
            unions(a,b);
            a=b;
        }
        int p=getParent(a);
        member[p]++;//可以保证人员总共增加N个 
    }
    int cnt=0;
    for(int i=0;i<maxn;++i){
        if(member[i]!=0)
            cnt++;
    }
    cout<<cnt<<endl;
    sort(member,member+maxn,cmp);
    for(int i=0;i<cnt;++i){
        cout<<member[i];
        if(i<cnt-1)
            cout<<' ';
    }
    cout<<endl;
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值