PAT A1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

思路:在各考场录入完毕时进行场内排序,确定场内编号,之后再全场排序即可

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=30010;

struct test{
    char number[20];//最开始用的double,但最后3分的样例过不去 
    int location;
    int score;
    int rank;//全场排序 
    int subrank;//内场排序 
}testee[maxn];
bool cmp(struct test a,struct test b){
    if(a.score!=b.score)
        return a.score>b.score;
    else
        return strcmp(a.number,b.number)<0;
}//按照总分从大到小,相同分数编号从小到大的顺序 
int main(){
//  freopen("in.txt","r",stdin);
//  freopen("out.txt","w",stdout);
    int N,K,i,j;
    int t=0;
    int total=0;
    cin>>N;
    for(i=0;i<N;i++){
        cin>>K;
        total+=K;
        for(j=t;j<K+t;j++){
            cin>>testee[j].number;
            cin>>testee[j].score;
            testee[j].location=i+1;
        }
        sort(testee+t,testee+t+K,cmp);//场内sort 
        for(int l=t;l<K+t;l++){
            testee[l].subrank=l-t+1;
            if(testee[l].score==testee[l-1].score&&l>t)
                testee[l].subrank=testee[l-1].subrank;
        } 
        t=j;        
    }
    sort(testee,testee+total,cmp);//全场sort 
    cout<<total<<endl;
    for(int i=0;i<total;i++){
        testee[i].rank=i+1;
        if(testee[i].score==testee[i-1].score&&i>0){
            testee[i].rank=testee[i-1].rank;
        }
        cout<<testee[i].number<<' '<<testee[i].rank<<' '<<testee[i].location<<' '<<testee[i].subrank<<endl;
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值