poj - 2506 Tiling--递推

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251
大数加法,抵退公式f(n) = f(n-1) + f(n-2)*2;
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
        int len;
        int s[300];
}ls[255];
void dasu(int n)
{
        int i ,c = 0;
        ls[n] = ls[n-2];
        for(i = 0; i < 300; i++)
        {
                ls[n].s[i] += (ls[n-2].s[i] + c);
                c = ls[n].s[i]/10;
                ls[n].s[i] %=10;
        }
         for(i = 0; i < 300; i++)
        {
                ls[n].s[i] += (ls[n-1].s[i] + c);
                c = ls[n].s[i]/10;
                ls[n].s[i] %=10;
        }
        for(i = 300; i >= 0; i--)
        {
                if(ls[n].s[i] != 0)
                        break;
        }
        ls[n].len = i + 1;
}
int main()
{
        int n; int i;
        ls[0].s[0] = 1;
        ls[0].len = 1;
        ls[1].s[0] =1;
        ls[1].len = 1;
        ls[2].s[0] = 3;
        ls[2].len = 1;
        ls[3].s[0] = 5;
        ls[3].len = 1;
        for(i = 4; i <= 250; i++)
        {
                dasu(i);
        }
        while(~scanf("%d",&n))
        {
            for(i = ls[n].len-1;i >= 0; i--)
            {
                    printf("%d",ls[n].s[i]);
            }
            printf("\n");
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值