poj-1068 Parencodings--模拟法

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题意:一个括号表达式可以按照如下的规则表示,就是每个右括号之前的左括号数。
比如(((()()()))),每个右括号之前的左括号数序列为P=4 5 6 6 6 6,而每个右括号所在的括号内包含的括号数为W=1 1 1 4 5 6.
现在给定P,输出W。
我的思路:先根据P还原整个括号表达式,存在数组中,然后递归解出W..
另外,用1代表左括号,0,代表又括号,运用栈的思想

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
 int ls[150], a[150], lb[150];
 void fun(int n,int m)
 {
         int kk[150];
         int tp, tl, t = 0;
         kk[0] = a[n];
         tl = n-1;
         tp = 1;
         while(tl >= 0)
         {
                 if(kk[tp-1] == 0 && a[tl] == 1)
                 {
                         t++;
                         tp--;
                         if(tp == 0)
                         {
                                  lb[m] = t;
                                  return;
                         }
                         tl--;
                 }
                 if(a[tl] == 0)
                 {
                         kk[tp++] = a[tl--];
                 }
         }
 }
int  main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m,i,j;
        memset(a,0,sizeof(a));
        memset(lb,0,sizeof(lb));
        scanf("%d",&m);
        for(i = 0; i < m; i++)
        {
                scanf("%d",&ls[i]);
        }
        int k = 0;
        for(i = 0; i < ls[0]; i++)
        {
                a[i] = 1;
        }
        k = i+1;
        for(i = 1; i < m; i++)
        {
                int mm = ls[i] - ls[i-1];
                for(j = 0; j < mm; j++)
                        a[k++] = 1;
                k++;
        }
        int c = 0;
        for(i = 1; i <= m; i++)
        {
                c = 0;
                for(j = 0; j < k; j++)
                {
                        if(a[j] == 0)
                               c++;
                        if(c == i)
                                break;
                }
                fun(j,i-1);
        }
        for(i = 0; i  < m; i++)
        {
                printf("%d",lb[i]);
                if(i < m-1)
                        printf(" ");
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值