poj 1068

 
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19550 Accepted: 11804

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题目分析:
       poj的一道英文题目,读了好久啊还借助了别人的翻译指导。此题多组处理数据,每组输入n个数,每个a[i]代表当前对应的右括号前面共有多少个左括号。
    比如:n=6, 4 5 6 6 6 6 。 对应第一个右括号前有4个左括号,第二个右括号前有5个左括号,不过千万不要落下第一个右括号啊,以此类推下去。。。。。。   
     现在要求输出另一个数组,数组元素为当前右括号包含的括号总数!
   比如:(()())
   第一个右括号只包含自己,故为 1;
   第二个右括号也只包含自己, 故为 1;
   第三个右括号包含前面两个括号,再加上自己,故为 3.
   所以应输出:1 1 3 ;

算法思路:根据n个数的数组模拟出原来的括号字符串,而我用的整形数组代替的,就是用1代表'(',用2代表‘)’,然后对这个整形数组处理。
    样例解析:
            (((()()()))))
             1 1 112 12 12 2 2 2 2
     标记数组:0 0 000 00 00 0 0 0 0
   第一次处理:0 0 011..............等

    标记数组遇到"2"则变成“1”。此时找到2了,则往2的前面去找1,也就是所谓的左括号,然后将找到的左括号标记为1,接下来将
    该输出的数存入输出数组,计算公式为:(i-j+1)/2; i为右括号的下标,j为找到的匹配的左括号的下标。




#include<stdio.h>
#include<string.h>
int a[30],b[100],c[100],d[100],dd,e;//a[]储存两个右括号左括号的个数  b[]将左括号赋值为1,右括号赋值为2,c[]标记
int main()
{
      int t,n,i,j,k;
      scanf("%d",&t);
      while(t--)
      {
              e=0;
              scanf("%d",&n);
              scanf("%d",&a[0]);
              for( i=0 ; i<a[0];i++)//b[]将左括号赋值为1,右括号赋值为2
                  b[e++]=1;
                  b[e++]=2;
                  for(i=1; i<n;i++)
                  {
                      scanf("%d",&a[i]);
                        for(j=0;j<a[i]-a[i-1];j++)
                            b[e++]=1;
                         b[e++]=2;
                  }
                  memset(c,0,sizeof(c));
                  dd=0;
                  for( i = 0 ; i<e ; i++)
                  {
                           if(b[i]==2&&c[i]==0)//c数组标记变量  看是否已经匹配
                           {
                               c[i]=1;
                                for( j=i-1;j>=0;j--)
                                    if(b[j]==1&&c[j]==0)
                                {
                                          c[j]=1;
                                          d[d++]=(i-j+1)/2;//括号的数目就是两个下标相减+1除以2就是了
                                          break;
                                }
                           }
                  }
                  for( k =0; k<dd;k++)
                  {
                      printf("%d%c",d[k],k==dd-1?'\n':' ');
                  }
                  
      }
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值