DFS----Red and Black (POJ1979)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

#include<iostream>
using namespace std;
char m[20][20];
int x, y;
void fun(int _x, int _y, int &count)
{
	if (_y >= y || _x >= x)return;
	if (_y < 0 || _x < 0)return;
	if (m[_x][_y] == '.'){
		count++;
		m[_x][_y] = '#';
	}
	if (m[_x - 1][_y] == '.')fun(_x - 1, _y, count);
	if (m[_x + 1][_y] == '.')fun(_x + 1, _y, count);
	if (m[_x][_y+1] == '.')fun(_x, _y + 1, count);
	if (m[_x][_y-1] == '.')fun(_x, _y - 1, count);
}
int main()
{
	int _x, _y;
	int count;
	while (cin >> y>> x){
		if (!x || !y)break;
		count = 1;
		for (int i = 0; i < x;++i)
		for (int j = 0; j < y; ++j){
			cin >> m[i][j];
			if (m[i][j] == '@')
				_x = i, _y = j;
		}
		fun(_x,_y,count);
		cout << count << endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值