题目:Power Strings(电源线) (POJ-2406)

题目:Power Strings (电源线)


Given two strings a and b we define a b to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

中文大意:

给定两个字符串 a 和 b,我们将 ab 定义为它们的串联。例如,如果 a = “abc” 和 b = “def” 那么 ab = “abcdef”。如果我们将串联视为乘法,则非负整数取幂以正常方式定义:a^0 = “”(空字符串)和 a^(n+1) = a*(a^n)。
输入
每个测试用例是一行代表 s 的输入,一串可打印的字符。s 的长度至少为 1,并且不会超过 100 万个字符。包含句点的行跟在最后一个测试用例之后。
输出
对于每个 s,您应该打印最大的 n,使得某些字符串 a 的 s = a^n。
样本输入
abcd
aaaa
ababab
.
样本输出
1
4
3
暗示
这个问题的输入量很大,使用scanf代替cin来避免超过时间限制。

题目大意:本题输入为多实例,每组测试样例为一串字符,遇到点停止输入,对于每个字符串,打印最大的n,n为最小的公共前后缀的最大出现次数。

解题思路:再输入每组数据字符串之后,获取这个字符串的next数组,然后判断字符串长度对长度减next[字符串长度]是否为0,如果是0,则输出长度除以长度减next[字符串长度],如果不为0,那就输出1。

错误分析:本题的输入量很大,为了防止超时,应避免用cin输入,而是应该用scanf。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[1000010];
int nex[1000010];
int slen;

void gtnext()
{
	int k=-1;int j=0;
	while(j<slen)
	{
		if(k==-1||str[j]==str[k])
		{
			j++;k++;
			nex[j]=k;
		}
		else k=nex[k];
	}
	return ;
}//比较常见的一种求next数组的模板

int main()
{
	while(cin>>str)
	{
		if(str[0]=='.') break; 
		slen=strlen(str);
		nex[0]=-1;
		gtnext();
		if(slen%(slen-nex[slen])==0)//长度减去公共前后缀的长度后还能被整除
			cout<<slen/(slen-nex[slen])<<endl;输出即为本题所求
		else cout<<"1"<<endl;不能被整除直接输出-1}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值