Cyclic Nacklace(循环项链)(kmp经典模板题) HDU - 3746

题目:Cyclic Nacklace(循环项链)

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

在这里插入图片描述

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5

中文大意:

CC这个月底总是很郁闷,昨天查了一下信用卡,不出意外,只剩下99.9元了。他太心疼了,想着如何度过最后的日子。受到“HDU CakeMan”创业精神的启发,他想卖一些小东西来赚钱。当然,这不是一件容易的事。

圣诞节快到了,男孩们忙着挑选圣诞礼物送给他们的女朋友。相信链式手链是一个不错的选择。然而,事情并不总是那么简单,众所周知,女孩喜欢用五颜六色的装饰来让手链显得生动活泼,同时也想展现自己作为大学生成熟的一面。CC了解女孩的诉求后,打算出售名为CharmBracelet的链式手链。CharmBracelet由色彩缤纷的珍珠组成,展现出少女的活泼,最重要的是它必须由一条环状链连接,这意味着珍珠的颜色是从左到右循环连接的。并且循环计数必须大于一。如果你把这条链子最左边的珍珠和最右边的珍珠连接起来,你可以做一个CharmBracelet。就像下图,这个 CharmBracelet 的周期是 9,它的周期数是 2:
在这里插入图片描述

现在CC带来了一些普通的手链链,他想购买最少数量的珍珠来制作CharmBracelets,这样他就可以节省更多的钱。但是在重新制作手链时,他只能在链的左端和右端添加彩色珍珠,也就是说,在中间添加是被禁止的。
CC 对他的想法很满意,并向您寻求帮助。
输入
输入的第一行是一个整数 T ( 0 < T <= 100 ),表示测试用例的数量。
每个测试用例只包含一行描述要重新制作的原始普通链。字符串中的每个字符代表一颗珍珠,用’a’~'z’字符描述的珍珠共有26种。字符串 Len 的长度:( 3 <= Len <= 100000 )。
输出
对于每种情况,您都需要输出为制作 CharmBracelet 添加的最少珍珠数。
样本输入
3
aaa
abca
abcde
样本输出
0
2
5

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[100010];
int nex[100010];
int slen;

void gtnext()
{
	int k=-1;int j=0;
	while(j<slen)
	{
		if(k==-1||str[j]==str[k])
		{
			j++;k++;
			nex[j]=k;
		}
		else k=nex[k];
	}
	return ;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",str);
		slen=strlen(str);
		nex[0]=-1;
		gtnext();
		int tp=slen-nex[slen];
		if(slen%tp==0&&slen!=tp)
			cout<<"0"<<endl;
		else cout<<tp-slen%tp<<endl;
		}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值