PAT菜鸡进化史_乙级_1050
本题要求将给定的 N 个正整数按非递增的顺序,填入“螺旋矩阵”。所谓“螺旋矩阵”,是指从左上角第 1 个格子开始,按顺时针螺旋方向填充。要求矩阵的规模为 m 行 n 列,满足条件:m×n 等于 N;m≥n;且 m−n 取所有可能值中的最小值。
输入格式:
输入在第 1 行中给出一个正整数 N,第 2 行给出 N 个待填充的正整数。所有数字不超过 104,相邻数字以空格分隔。
输出格式:
输出螺旋矩阵。每行 n 个数字,共 m 行。相邻数字以 1 个空格分隔,行末不得有多余空格。
输入样例:
12
37 76 20 98 76 42 53 95 60 81 58 93
输出样例:
98 95 93
42 37 81
53 20 76
58 60 76
思路:
哇这个贼烦的!一开始直接按照右下左上的顺序填充,结果发现这样会有bug(不信大家写个4 * 4以上的试一下!)
然后发现还得关注上一步的填充方向,优先相同,不能填的时候才换方向!
Code:
#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
int main(){
using namespace std;
// sort the input numbers
int N;
cin >> N;
vector<int> num(N);
for (int i= 0; i < N; i++)
cin >> num[i];
sort(num.begin(), num.end());
reverse(num.begin(), num.end());
// calculate the row and column
int row, column;
column = sqrt(N);
while (N % column)
column--;
row = N / column;
// fill the matrix
vector<vector<int> > matrix(row, vector<int> (column));
int matrix_i = 0, matrix_j = 0, flag = 0;
for (int i = 0; i < N; i++){
matrix[matrix_i][matrix_j] = num[i];
switch(flag){
case 0:
flag = (matrix_j + 1 < column && matrix[matrix_i][matrix_j + 1] == 0) ? 0 : 1;
break;
case 1:
flag = (matrix_i + 1 < row && matrix[matrix_i + 1][matrix_j] == 0) ? 1 : 2;
break;
case 2:
flag = (matrix_j - 1 > -1 && matrix[matrix_i][matrix_j - 1] == 0) ? 2 : 3;
break;
case 3:
flag = (matrix_i - 1 > -1 && matrix[matrix_i - 1][matrix_j] == 0) ? 3 : 0;
break;
}
switch(flag){
case 0: matrix_j++; break;
case 1: matrix_i++; break;
case 2: matrix_j--; break;
case 3: matrix_i--; break;
}
}
// display the matrix
for (int i = 0; i < row; i++){
for (int j = 0; j < column; j++){
cout << matrix[i][j];
if (j != column - 1)
cout << " ";
else
cout << "\n";
}
}
return 0;
}