状压DP(例题:HDU1074)

6 篇文章 0 订阅

状压DP:用到状压的DP。

什么是状压?

把一系列状态压缩成一个状态(通常用二进制)。

 

例题:HDU1074

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12604    Accepted Submission(s): 6079

 

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

 

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

 

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

 

Source

HDU1074

 

题意:有n个任务,每个任务有一个截止时间,超过截止时间一天,要扣一个分。求如何安排任务,使得扣的分数最少。

分析:可以将每一个任务完成看成1,未完成看成0,则每一种状态可以转换成一个n位二进制,换算成十进制就是0-2^n-1

这样就可以进行dp了(代码中进行了注释)。

 

代码:

#include <iostream>
#include <cstdio>
const int inf=0x3f3f3f3f;
const int MAX=(1<<15)+10;
using namespace std;

//dp记录到达状态i扣的最少的分
//t为达到i花的时间
//pre记录路径
//ddl为截止时间,len为时长
int n,dp[MAX],t[MAX],pre[MAX],ddl[20],len[20];
char s[20][110];

void output(int x)
{
	if(!x)return;
	output(x-(1<<pre[x]));
	printf("%s\n",s[pre[x]]);
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			scanf("%s%d%d",s[i],&ddl[i],&len[i]);
		//设置上限,1<<n表示2^n
		int bit=1<<n;
		
		for (int i=1;i<bit;i++)
		{
			dp[i]=inf;
			for (int j=n-1;j>=0;j--)
			{
				int temp=1<<j;
				//如果第j位不为1说明不能从i-temp转移过来
				if (!(i&temp))
					continue;
				//扣分为上一个状态的时间+长度-截止时间
				int score=t[i-temp]+len[j]-ddl[j];
				//如果发现扣分为负则不需要扣分
				if (score<0)
					score=0;

				if (dp[i]>dp[i-temp]+score)
				{
					//更新dp
					dp[i]=dp[i-temp]+score;
					//更新花的时间
					t[i]=t[i-temp]+len[j];
					//记录路径
					pre[i]=j;
				}
			}
		}
		printf("%d\n",dp[bit-1]);
		output(bit-1);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值