ZOJ - 3953Intervals(贪心)

Intervals

Time Limit: 1 Second       Memory Limit: 65536 KB       Special Judge

Chiaki has n intervals and the i-th of them is [liri]. She wants to delete some intervals so that there does not exist three intervals ab and c such that a intersects with bb intersects with c and c intersects with a.

Chiaki is interested in the minimum number of intervals which need to be deleted.

Note that interval a intersects with interval b if there exists a real number x such that la ≤ x ≤ ra and lb ≤ x ≤ rb.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1 ≤ n ≤ 50000) -- the number of intervals.

Each of the following n lines contains two integers li and ri (1 ≤ li < ri ≤ 109) denoting the i-th interval. Note that for every 1 ≤ i < j ≤ nli ≠ lj or ri ≠ rj.

It is guaranteed that the sum of all n does not exceed 500000.

Output

For each test case, output an integer m denoting the minimum number of deletions. Then in the next line, output m integers in increasing order denoting the index of the intervals to be deleted. If m equals to 0, you should output an empty line in the second line.

Sample Input
1
11
2 5
4 7
3 9
6 11
1 12
10 15
8 17
13 18
16 20
14 21
19 22
Sample Output
4

3 5 7 10

题目大意:

给你n个区间的左右端点,让你取走一些区间,使得任何三个区间都不两两相交。

思路:

贪心,首先将所有区间以左端点从小到大排序,然后每次判断当前的三个区间是否两两相交,如果两两相交则删除右端点值最大的那个区间,因为这样对后面的影响会最小。如果不相交则继续添加区间,每三个一判断。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 50005;
struct Intervals
{
    int l, r, id;
}a[maxn], tmp[5];
bool cmp1(Intervals p, Intervals q)
{
    if(p.l == q.l)
        return p.r < q.r;
    return p.l < q.l;
}
bool cmp2(Intervals p, Intervals q)
{
    return p.r > q.r;
}
bool isInterval(Intervals x, Intervals y, Intervals z)
{
    return y.l <= x.r && z.l <= y.r && z.l <= x.r;
}
int ans[maxn], cnt;
int main()
{
    int n, T;
    scanf("%d", &T);
    while(T--)
    {
        cnt = 0;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d%d", &a[i].l, &a[i].r);
            a[i].id = i;
        }
        sort(a+1, a+n+1, cmp1);
        tmp[1] = a[1];
        tmp[2] = a[2];
        for(int i = 3; i <= n; i++)
        {
            tmp[3] = a[i];
            sort(tmp+1, tmp+4, cmp1);
            if(isInterval(tmp[1], tmp[2], tmp[3]))
            {
                sort(tmp+1, tmp+4, cmp2);
                ans[cnt++] = tmp[1].id;
                swap(tmp[1], tmp[3]);
            }
            else
                sort(tmp+1, tmp+4, cmp2);
        }
        sort(ans, ans+cnt);
        printf("%d\n", cnt);
        for(int i = 0; i < cnt; i++)
            printf("%d%c", ans[i], i == cnt-1 ? '\n' : ' ');
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值