poj1258 Agri-Net

Agri-Net

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

Sample Output

28

 

题目大意:有n个农场,已知这n个农场都互相相通,有一定的距离,现在每个农场需要装光纤,问怎么安装光纤能将所有农场都连通起来,并且要使光纤距离最小,输出安装光纤的总距离
解题思路:又是一个最小生成树,因为给出了一个二维矩阵代表他们的距离,直接算prim就行了

 

 

 

 

#include<algorithm>

#include<cstdio>

#include<cstring>

#include<iostream>

using namespace std;

#define INF 99999999

int n;

int mp[108][108];

int used[108],low[108];

int prime(int n)

{

    int sum=0,i,time=1,k;

    memset(used,0,sizeof(used));//清零

    used[0]=1;//选取第一个点

    for(i=1;i<n;i++)

    {

        low[i]=mp[0][i];//与第一个点相连的线段的权值存在数组中

    }

    while(time<=n-1)//因为每循环一次找出一个点,所以只要循环n-1次一定能够把最小生成树找出来

    {

        int it=INF;//先将最小值设成一个大数

        int j=0;

        for(k=1;k<n;k++)

        {

            if(low[k]<it&&used[k]==0)//找两个点之间的最短距离且另一个点没用过

            {

                it=low[k];//更新最小值

                j=k;

            }

        }

        sum=sum+it;//加上最小值

        used[j]=1;//这个点用过标记为1

        for(k=1;k<n;k++)

        {

            if(mp[j][k]<low[k]&&used[k]==0)//找这个点与其他点之间的最短距离且另一个点也没用过

            {

                low[k]=mp[j][k];//更新最小值

            }

        }

        time++;

    }

    return sum;

}

int main()

{

    while(cin>>n)

    {

        for(int i=0;i<n;i++)

        {

            for(int j=0;j<n;j++)

            {

                cin>>mp[i][j];//ij的权值

            }

        }

        cout<<prime(n)<<endl;

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值