How Many Tables(并查集)

How Many Tables(并查集)

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

翻译:

今天是伊格纳修斯的生日。他邀请了很多朋友。现在是吃晚饭的时候了。伊格纳修斯想知道他至少需要几张桌子。你必须注意到不是所有的朋友都认识对方,所有的朋友都不想和陌生人呆在一起。
这个问题的一个重要规则是,如果我告诉你A知道B,B知道C,这意味着A,B,C互相了解,所以他们可以呆在一张桌子上。
例如:如果我告诉你a知道b,b知道c,d知道e,那么a,b,c可以放在一张桌子上,d,e必须放在另一张桌子上。所以伊格纳修斯至少需要两张桌子。

input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

翻译:

输入以整数t(1<=t<=25)开始,表示测试用例的数量。接下来是t个测试用例。每个测试用例以两个整数n和m(1<=n,m<=1000)开头。n表示朋友的数量,从1到n标记朋友,然后m行跟随。每一行包含两个整数A和B(A!=B),意思是朋友A和朋友B互相认识。两个案例之间会有一个空行。

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

翻译:

对于每个测试用例,只需输出伊格纳修斯至少需要多少个桌子。不要打印任何空白。

Sample input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample output

2
4

感觉是最简单的并查集问题了,唯一的难点可能就是路径压缩吧,重要的是要思路清晰和准确理解题意。、

代码如下:

#include<cstdio>
#include<iostream>

using namespace std;

int frend[1111];
int m,n;
void init()  //初始化数组 
{
	for(int k=1;k<=n;k++)
	frend[k]=k;
}
int find(int x)    //查询父节点,直到没有父节点 ,并进行路径压缩,即将所有的点归于同一父节点下 
{
	return frend[x]==x?x:frend[x]=find(frend[x]);//这样  处于同一父节点下的   可以放在同一桌  
}
void Union(int x,int y)  //连接两个人   将两个有朋友关系的人 连接起来 
{
	int p1=find(x);
	int p2=find(y);
	if(p1!=p2)
	frend[p1]=p2;
}
int main()
{
	int t;
	scanf("%d",&t);  //几个案例 
	for(int i=1;i<=t;i++)
	{
		scanf("%d%d",&n,&m);    //n个人   m个关系 
		init();            //每个案例都要初始化 
		for(int j=1;j<=m;j++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			Union(a,b);        //连接 
		}
		int sum=0;
		for(int l=1;l<=n;l++)
		{	
			if(frend[l]==l)         //判断需要多少桌子    一个父节点一张桌子 
			sum++;
		}
		printf("%d\n",sum);       //输出 
	}
	
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

努力的小朱同学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值