Is It A Tree?
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
Poj能过的代码:
#include <stdio.h>
int i;
int s[1000];
int flag = 1; //flag为0标志着不是树
void init() //初始化操作
{
for (i = 1; i < 1000; i++)
s[i] = i;
}
int Find(int n)
{
if(n==s[n])
return n;
else
return Find(s[n]);
}
void Merge(int n, int m) //合并操作
{
if (n == m)
flag = 0;
else if (s[m] == m)//根节点
s[m] = n;
else
flag = 0;
}
int main()
{
int n, m;
int times = 1, first = 0, root;
init();
while (scanf("%d %d", &n, &m) != EOF)
{
if (n < 0 || m < 0)
break;
if (n == 0 && m == 0)
{
for (i = 0; i < 1000; i++)
{
if (first == 0 && s[i] != i) //找到第一个父节点不是本身的节点
{
first = 1;
if (s[s[i]] == i) //说明存在环
{
flag = 0;
break;
}
root = Find(i); //确定根节点
}
else if (first == 1 && s[i] != i)
{
if (root != Find(i)) //看是否有一个根节点
flag = 0;
}
}
if (flag == 1)
printf("Case %d is a tree.\n", times++);
else
printf("Case %d is not a tree.\n", times++);
init();
flag = 1;
first = 0;
}
else
{
Merge(n, m); //执行合并,将m的父节点置为n
}
}
return 0;
}
这个是有向的。。。和前面的差别很大。。。poj上的数据比hdu上的数据更奇怪。。。
还有一种思想是判断入入度的
入度:指向这个数的有几个数(有方向)
1,无环;2,除了根,所有的入度为1,根入度为0;3,这个结构只有一个根,不然是森林了。再注意这里空树也是树。
Hdu能过poj过不去。。。
Hdu能过的代码:
#include<iostream>
using namespace std;
int r=0;
bool flag=true;
int pre[10008];
int mark[10008];
int rudu[10008];
int Find(int n)
{
if(n!=pre[n])
{
pre[n]=Find(pre[n]);
}
return pre[n];
}
void Merge(int x,int y)
{
int fx=Find(x);
int fy=Find(y);
if(fx==fy)
return ;
pre[fx]=fy;
mark[fy]=1;
mark[fx]=0;
}
void init()
{
r=0;
flag=true;
for(int i=0;i<10008;i++)
{
pre[i]=i;
mark[i]=0;
rudu[i]=0;
}
}
int main()
{
int x,y,t=1;
init();
while(cin>>x>>y,x>=0&&y>=0)
{
if(!x&&!y)
{
for(int i=0;i<=10008;i++)
{
if(rudu[i]>1)
flag=false;
if(mark[i])
r++;
}
if(r>1)
flag=false;
if(flag)
cout<<"Case "<<t++<<" is a tree."<<endl;
else
cout<<"Case "<<t++<<" is not a tree."<<endl;
init();
continue;
}
if(Find(x)!=Find(y))
Merge(x,y);
rudu[y]++;
}
return 0;
}