HDU 1009 FatMouse' Trade

14 篇文章 0 订阅

A - FatMouse' Trade

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains Ji pounds of JavaBeans and requires Fi pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get Ji* a% pounds of JavaBeans if he pays Fi

* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers Ji

and Fi

respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

 

 

按性价比排序,然后再拿总猫粮去诱惑猫,并取得食物;

第一个数据表示能拿几个

第二个数据表示有几组

输入的是总的猫粮对应的价值

要除一下算性价比。

 

 

 

 

 

#include<stdio.h>

#include<algorithm>

using namespace std;

struct hanshu

{

    double a;

    double b;

    double shang;

}c[10000];

int cmp(struct hanshu q,struct hanshu w)

{

    return q.shang>w.shang;

}

int main()

{

    int m,n,i;

    while(scanf("%d%d",&m,&n)!=EOF)

    {

        double sum=0;

        if(m==-1&&n==-1)

            break;

        for(i=0;i<n;i++)

        {

            scanf("%lf%lf",&c[i].a,&c[i].b);

            c[i].shang=c[i].a/c[i].b;

        }

        sort(c,c+n,cmp);

        for(i=0;i<n;i++)

        {

            if(m>c[i].b)

            {

                m=m-c[i].b;

                sum=sum+c[i].a;

            }

            else

            {

                sum=sum+m*c[i].shang;

                break;

            }

        }

        printf("%.3lf\n",sum);

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值