hdu 2136 Largest prime factor题解

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15589    Accepted Submission(s): 5406


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
 
 
12345
 
Sample Output
 
 
01213
 

Author
Wiskey
 

Source

HDU 2007-11 Programming Contest_WarmUp 

题意:求n的最大质因子在素数中的位置。

思路:使用埃氏筛法打素数表,对于不是素数的数,每次更新他的最大的质因子。

AC代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
using namespace std;
const int MAXN = 1e6+10;
int LPF[MAXN];
//素数筛选
void init(){
	memset(LPF,0,sizeof(LPF));
	int cnt=1;
	for(int i=2;i<MAXN;i++){
		if(!LPF[i]){
			for(int j=i;j<MAXN;j=j+i){
				LPF[j]=cnt;//对于不是素数的数,每次更新他的最大的质因子。
			}
			cnt++;
		}
	}
}

int main(){
	init();
	int n;
	while(~scanf("%d",&n)){
		printf("%d\n",LPF[n]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值