HOJ 2085 - Wavio Sequence(LIS)

今天小测的ProblemC。
传送门:http://acm.hit.edu.cn/hojx/showproblem/2085/
2085 - Wavio Sequence

Time limit : 1 s Memory limit : 32 mb
Submitted : 302 Accepted : 126
Submit

Problem Description
Wavio is a sequence of integers. It has some interesting properties.

Wavio is of odd length i.e. L = 2 * n + 1.
The first (n+1) integers of Wavio sequence makes a strictly increasing sequence.
The last (n+1) integers of Wavio sequence makes a strictly decreasing sequence.
No two adjacent integers are same in a Wavio sequence.
For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an Wavio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is not a valid wavio sequence. In this problem, you will be given a sequence of integers. You have to find out the length of the longest Wavio sequence which is a subsequence of the given sequence. Consider, the given sequence as :

1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.
Here the longest Wavio sequence is: 1 2 3 4 5 4 3 2 1. So, the output will be 9.

Input
The input file contains multiple test cases. The description of each test
case is given below. Input is terminated by end of file.

Each set starts with a postive integer, N(1 ≤ N ≤ 10000). In next few lines there will be N integers.

Output
For each set of input print the length of longest wavio sequence in a line.

Sample Input

10
1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5
Sample Output

9
9
1

就是求最长上升子序列问题,简单的来说这种Wavio序列要求的是
1.这个序列个数是奇数;
2.前n+1个数是严格上升的,后n+1个数是严格下降的;
3.相邻的两数不能相同(和第二点其实有些重合)
小测的时候就是第三点没有把握好导致WA的!!

知道以上规则后就明白要干什么了,注意看时间要求,必须要用nlogn的方法求上升子序列。
还要把每个数的之前的最大上升数记下来,正着来一遍倒着来一遍就好了。

AC代码如下:

#include <stdio.h>
#include <string.h>
#define maxn 10005

int a[maxn];
int b[maxn];
int ansa[maxn];
int ansb[maxn];
int ca[maxn];
int cb[maxn];
int MAX(int a, int b)
{
    return a > b ? a : b;
}
int MIN(int a, int b)
{
    return a < b ? a : b;
}
int main()
{
    int n;
    while(scanf("%d", &n) != EOF && n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            b[n-i+1] = a[i];
        }
        memset(ansa, 0, sizeof(ansa));
        int lena = 1;
        ansa[1] = a[1];
        ca[1] = 1;
        for(int i = 2; i <= n; i++)
        {
            if(a[i] > ansa[lena])
            {
                ansa[++lena] = a[i];
                ca[i] = lena;
            }

            else
            {
                int left = 0, right = lena;
                int mid;
                while(left < right)
                {
                    mid = (left + right) / 2;
                    if(ansa[mid] >= a[i])
                        right = mid;
                    else
                        left = mid + 1;
                }
                ansa[left] = a[i];
                ca[i] = left;
            }
        }
        memset(ansb, 0, sizeof(ansb));
        int lenb = 1;
        ansb[1] = b[1];
        cb[1] = 1;
        for(int i = 2; i <= n; i++)
        {
            if(b[i] > ansb[lenb])
            {
                ansb[++lenb] = b[i];
                cb[i] = lenb;   
            }

            else
            {
                int left = 0, right = lenb;
                int mid;
                while(left < right)
                {
                    mid = (left + right) / 2;
                    if(ansb[mid] >= b[i])
                        right = mid;
                    else
                        left = mid + 1;
                }
                ansb[left] = b[i];
                cb[i] = left;
            }
        }
        int an = 0;
        for(int i = 1; i <= n; i++)
        {
            an = MAX(an, MIN(ca[i], cb[n-i+1]) * 2 - 1);
        }
        printf("%d\n", an);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值