Wavio Sequence (最长上升子序列)

Wavio is a sequence of integers. It has some interesting properties.
• Wavio is of odd length i.e. L = 2 ∗ n + 1.
• The first (n + 1) integers of Wavio sequence makes a strictly increasing sequence.
• The last (n + 1) integers of Wavio sequence makes a strictly decreasing sequence.
• No two adjacent integers are same in a Wavio sequence.
For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an Wavio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is
not a valid wavio sequence. In this problem, you will be given a sequence of integers. You have to find
out the length of the longest Wavio sequence which is a subsequence of the given sequence. Consider,
the given sequence as :
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.
Here the longest Wavio sequence is : 1 2 3 4 5 4 3 2 1. So, the output will be ‘9’.
Input
The input file contains less than 75 test cases. The description of each test case is given below. Input
is terminated by end of file.
Each set starts with a postive integer, N (1 ≤ N ≤ 10000). In next few lines there will be N
integers.
Output
For each set of input print the length of longest wavio sequence in a line.
Sample Input
10
1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5
Sample Output
9
9
1

题目大概:

在n个序列中求最长的一个山峰形状的序列,山的两个腰要相等。

思路:

求两边最长上升子序列。

遍历一遍,求左右两个方向的最长上升子序列的小的一个。然后求出山峰的长度。

代码:

#include<bits/stdc++.h>

using namespace std;
const int maxn=1e5+100;
int dp[maxn],a[maxn];
int b[maxn],sum1[maxn],sum2[maxn];

void Lis1(int n)
{
    int len=1,i,low,high,mid;
    dp[1]=a[1];
    sum1[1]=1;
    for(i=2;i<=n;i++)
    {
       low=1;
       high=len;
       while(low<=high)
       {
           mid=(low+high)/2;
           if(a[i]>dp[mid])
               low=mid+1;
           else
               high=mid-1;
       }
       dp[low]=a[i];
       sum1[i]=low;
       if(low>len)
           len=low;
    }
}
void Lis2(int n)
{
    int len=1,i,low,high,mid;
    dp[1]=b[1];
    sum2[1]=1;
    for(i=2;i<=n;i++)
    {
       low=1;
       high=len;
       while(low<=high)
       {
           mid=(low+high)/2;
           if(b[i]>dp[mid])
               low=mid+1;
           else
               high=mid-1;
       }
       dp[low]=b[i];
       sum2[i]=low;
       if(low>len)
           len=low;
    }
}
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[n-i+1]=a[i];
        }

        Lis1(n);
        memset(dp,0,sizeof(dp));
        Lis2(n);
        int mi=0;
        for(int i=1;i<=n;i++)
        {
            int sum=min(sum1[i],sum2[n-i+1]);
            sum=sum*2-1;
            mi=max(mi,sum);
        }
        printf("%d\n",mi);

    }

    return 0;
}



  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值