题目:
Frogger
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 51723 | Accepted: 16420 |
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2 0 0 3 4 3 17 4 19 4 18 5 0
Sample Output
Scenario #1 Frog Distance = 5.000 Scenario #2 Frog Distance = 1.414
题意:给定n个点,任意两点都完全连通。求第一个点到第二个点的所有通路中最长的那个通路里的最小的边。
方法:floyd变形。求最长路中的最短边。将G数组定义为存储i到j最长路的最短边。改变floyd中的松弛条件即可。
WA点:%.3lf用c++交!!!用G++会无限WA。。。TnT
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<stack>
// #define Reast1nPeace
typedef long long ll;
using namespace std;
const int MAXN = 210;
int c;
struct node{
double x,y;
}Point[MAXN];
double dis(node a , node b){
double i = a.x - b.x;
double j = a.y - b.y;
return sqrt(i*i + j*j);
}
double G[MAXN][MAXN];
void floyd(){
for(int k = 1 ; k<=c ; k++){
for(int i = 1 ; i<=c-1 ; i++){
for(int j = i+1 ; j<=c ; j++){
if(G[i][j]>G[i][k] && G[i][j]>G[k][j] ){ //i到k的最短边,k到i的最短边都要小于原来的i到j的最短边,
//三角形两边之和大于第三边既保证了新的i到j的距离比原来长,又保证了 i到k的最短边,k到i的最短边其一为新的i到j的最短边
if(G[i][k] < G[k][j]){ //为了保证i到k到j连通,新的最短边应该选择二者中长的那个
G[i][j] = G[j][i] = G[k][j];
}
else{
G[i][j] = G[j][i] = G[i][k];
}
}
}
}
}
}
int main(){
#ifdef Reast1nPeace
freopen("in.txt", "r", stdin);
freopen("out.txt", "w", stdout);
#endif
int cases = 1;
while(scanf("%d",&c)!=EOF && c){
for(int i = 1 ; i<=c ; i++){
scanf("%lf%lf",&Point[i].x,&Point[i].y);
}
for(int i = 1 ; i<=c-1 ; i++){
for(int j = i+1 ; j<=c ; j++){
G[i][j] = G[j][i] = dis(Point[i],Point[j]);
}
}
floyd();
printf("Scenario #%d\n",cases++);
printf("Frog Distance = %.3lf\n\n",G[1][2]);
}
return 0;
}