Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5

# include <iostream>
# include <cstdio>
# include <string>
using namespace std;

/*因为用到了迭代的方法,一定要控制的迭代的次数,否则会出现栈溢出的情况。
分析问题可以推断,由于f(n)是由前两个数字组合产生,那么只要有两个数字组合相同的情况发生就一定一会产生循环!
两个数字的组合的最大可能值为7x7=49,因此只要在调用迭代方法中限制n的在0~48就可以了。
自认为本人这个程序比较容易接受,是迭代的方法。*/


int main()
{
	int a,b,n,i,f[51];
	f[1]=1;f[2]=1;
	while(scanf("%d%d%d",&a,&b,&n)!=EOF)
	{
		if(a==0&&b==0&&n==0)    break;
		n=n%49;
		for(i=3;i<=n;i++)    f[i]=(a*f[i-1]+b*f[i-2])%7;
		printf("%d\n",f[n]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值