Star

Description

Overpower often go to the playground with classmates. They play and chat on the playground. One day, there are a lot of stars in the sky. Suddenly, one of Overpower’s classmates ask him: “How many acute triangles whose inner angles are less than 90 degrees (regarding stars as points) can be found? Assuming all the stars are in the same plane”. Please help him to solve this problem.

Input

The first line of the input contains an integer T (T≤10), indicating the number of test cases.

For each test case:

The first line contains one integer n (1≤n≤100), the number of stars.

The next n lines each contains two integers x and y (0≤|x|, |y|≤1,000,000) indicate the points, all the points are distinct.


Output

For each test case, output an integer indicating the total number of different acute triangles.

Sample Input

1
3
0 0
10 0
5 1000

Sample Output


题意:给出一系列的点,要求求出能够组成锐角三角形的个数,锐角三角形的判断为其中较短的两条边的长度的平方和大于最大的边的长度的平方;

<span style="font-size:14px;"># include <cmath>
# include <cstdio>
# include <iostream>
# include <algorithm>
using namespace std;

double p[110][2];

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int i,j,k,ans=0;
        double a,b,c;
        for(i=0;i<n;i++)
            scanf("%lf%lf",&p[i][0],&p[i][1]);
        for(i=0;i< n-2;i++)
            for(j=i+1;j< n-1;j++)
                for(k=j+1;k< n;k++)
                {
                    a=(p[i][0]-p[j][0])*(p[i][0]-p[j][0])+(p[i][1]-p[j][1])*(p[i][1]-p[j][1]);
                    b=(p[j][0]-p[k][0])*(p[j][0]-p[k][0])+(p[j][1]-p[k][1])*(p[j][1]-p[k][1]);
                    c=(p[k][0]-p[i][0])*(p[k][0]-p[i][0])+(p[k][1]-p[i][1])*(p[k][1]-p[i][1]);
                    if(a+b>c && a+c>b && b+c>a )    ans++;
                }
        printf("%d\n",ans);
    }
    return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值