Brackets sequence

Description:

Let us define a regular brackets sequence in the following way:
1.Empty sequence is a regular sequence.
2.If S is a regular sequence, then (S) and [S] are both regular sequences.
3.If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1a2...an is called a subsequence of the string b1b2...bm, if there exist such indices 1 ≤ i1 < i2 < ... < in ≤ m, that aj=bij for all 1 ≤ j ≤ n.

Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.


The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input
1

([(]

Sample Output
()[()]


# include <cstdio>
# include <cstring>
# include <algorithm>
# include <iostream>
using namespace std;

int d[105][105],len;     //数组 d 的含义,从第 i 个字符到第 j 字符需要匹配多少括号;
char s[105];

bool match(char a , char b)    //判断是否括号匹配;
{
    if(a=='('&&b==')'|| a=='['&&b==']')    return true;
    else    return false;
}

void dp( )
{
    int i,j,k;
    for(i=0;i<len;i++)    //数据重置;
    {
        d[i+1][i]=0;
        d[i][i]=1;
    }
    for(i=len-2;i>=0;i--)    //从倒数第二个字符串开始;
    {
        for(j=i+1;j<len;j++)
        {
            d[i][j] = len;
            //如果最外层的括号是匹配的,那么把下标往里移动;
            if( match (s[i],s[j]) )  d[i][j] = min (d[i][j],d[i+1][j-1]);
            //继续寻找最优解;
            for(k=i;k<j;k++)
                d[i][j] = min ( d[i][j],d[i][k] + d[k+1][j] );
        }
    }
}

void print(int i,int j)    //其实就是倒推的过程;
{
    if( i>j )  return ;
    if( i==j )
    {
        if( s[i]=='('||s[i]==')' )    printf("()");
        else    printf("[]");
        return ;
    }
    int ans = d [i] [j];
    if( match(s[i],s[j]) && ans== d[i+1][j-1] )    //判断最外层的两个括号是不是匹配的,再看最优值是不是dp [i-1] [j+1];
    {
        printf("%c",s[i]);    print(i+1,j-1);    printf("%c",s[j]);    return ;
    }
    for( int k =i; k<j ;k++)
    {
        if( ans == d[i][k]+d[k+1][j] )
        {
            print( i, k);    print( k+1, j);    return ;
        }
    }
}

void readline(char *s)
{
    fgets(s,105,stdin);
}

int main()
{
    int n;
    readline(s);
    sscanf(s, "%d", &n);
    readline(s);
    while(n--)
    {
        readline(s);
        len=strlen(s)-1;
        memset(d,-1,sizeof(d));
        dp();
        print(0,len-1);
        cout<<"\n";
        if(n)    cout<<"\n";
        readline(s);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值