Brackets Sequence (POJ-1141)

Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

题意:给你一行括号,只有小括号()和中括号【】,令其匹配好,即左括号一定有个右括号匹配,然后把最短的匹配好的括号输出;


思路:区域DP,但是比较难的地方是输出,用pos把需要添加的地方记录下来,然后二分查找输出;


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0x3f3f3f3f
using namespace std;
int f[105][105],pos[105][105];
char s[105];
void fun(int x,int y)
{
    if(x>y) return;
    if(x==y){
        if(s[x]=='('||s[x]==')') printf("()");
        if(s[x]=='['||s[x]==']') printf("[]");
    }
    else if(x<y){
        if(pos[x][y]==-1){
            if(s[x]=='('){
                printf("(");
                fun(x+1,y-1);
                printf(")");
            }
            else{
                printf("[");
                fun(x+1,y-1);
                printf("]");
            }
        }
        else{
            fun(x,pos[x][y]);
            fun(pos[x][y]+1,y);
        }
    }
}
int main()
{
    scanf("%s",s);
    memset(f,0,sizeof(f));
    int len=strlen(s);
    for(int i=len;i>0;i--){
        s[i]=s[i-1];
        f[i][i]=1;
    }
    for(int l=1;l<=len;l++){
        for(int i=1;i<=len-l;i++){
            int j=l+i;
            f[i][j]=INF;
            if(s[i]=='('&&s[j]==')'||s[i]=='['&&s[j]==']'){
                if(f[i+1][j-1]<f[i][j]) f[i][j]=f[i+1][j-1];
            }
            pos[i][j]=-1;
            for(int k=i;k<j;k++){
                if(f[i][k]+f[k+1][j]<f[i][j]){
                    f[i][j]=f[i][k]+f[k+1][j];
                    pos[i][j]=k;
                }
            }
        }
    }
    fun(1,len);
    printf("\n");
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值