枚举 | POJ1753.Flip Game

枚举 | POJ1753.Flip Game

Link:POJ1753.Flip Game

Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

img

wwww
bwwb
bwww
wwwb

Input
The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

Northeastern Europe 2000

题意
如图4X4方格,每次选中一枚棋子,将它和它的上下左右变换颜色,问至少多少次,将棋盘的颜色统一,全部为白色或者全部为黑色

思路
1.从16个棋子中依次选取 0,1,2,3… 14, 15, 16个棋子反转,总次数为2^16
2.采用深度优先的方法从16个棋子当中选取n个数进行翻转操作,成功之后直接返回

#include <iostream>
using namespace std;

bool chess[6][6] = {false}; //6X6矩阵,统一边缘棋子和内部棋子操作
int r[5] = { -1, 0, 1, 0, 0 };//按照 上、右、下、左、中的方式进行遍历
int c[5] = { 0, 1, 0, -1, 0 };

int deep, step;
int row, col;
bool flag = false;

//判断是否为同一种颜色
bool isOver()
{
    int i, j;
    for( i = 1; i <= 4; i++ )
        for( j = 1; j <= 4; j++ )
        {
           if( chess[i][j] != chess[1][1] )
                return false;
        }
    return true;
}

//翻转
void flip( int row, int col )
{
    int i;
    for( i = 0; i < 5; i++ )
    {
        chess[ row+r[i] ][ col+c[i] ] = !chess[ row+r[i] ][ col+c[i] ];
    }
}

//使用DFS的方法遍历从16个棋子中找出step个棋子进行翻转的所有方法
void DFS( int row, int col, int deep )
{
    //递归出口: 翻转棋子个数deep自增到step
    //或者 已经找到全部翻转为白色的路径 或者 所有棋子全部已经翻转
    if( deep == step )
    {
        flag = isOver();
        return;
    }
    if( flag || row == 5 )
        return;

    //翻转当前(row,col)位置
    flip( row, col );

    //逐行进行递归
    if( col < 4 )
        DFS( row, col+1, deep+1 );
    else
        DFS( row+1, 1, deep+1 );

    //还原当前位置
    flip( row, col );

    //递归下一个棋子,此时深度不变
    if( col < 4 )
        DFS( row, col+1, deep );
    else
        DFS( row+1, 1, deep );
}

int main()
{
    //input
    int i, j;
    char c;
    for( i = 1; i < 5; i++ )
        for( j = 1; j < 5; j++ )
        {
            cin >> c;
            if( c == 'b' )
                chess[i][j] = false;
            else
                chess[i][j] = true;
        }
    //翻转0, 1, 2, 3... 15, 16个棋子
    for( step = 0; step <= 16; step++ )
    {
        DFS( 1, 1, 0 );
        if( flag )
            break;
    }

    if( flag )
        cout << step << endl;
    else
        cout << "Impossible" << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值