【HDU 3949】XOR

XOR

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1459    Accepted Submission(s): 438


Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 

Sample Input
  
  
2 2 1 2 4 1 2 3 4 3 1 2 3 5 1 2 3 4 5
 

Sample Output
  
  
Case #1: 1 2 3 -1 Case #2: 0 1 2 3 -1
Hint
If you choose a single number, the result you get is the number you choose. Using long long instead of int because of the result may exceed 2^31-1.
 

Author
elfness
 

Source


首先高斯消元,求第k大就是把k二进制拆分,是1的位的对应数异或就是答案。


对于0要特判。


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define LL long long
using namespace std;
int now,k,n,m,T;
LL a[10005];
void Gauss()
{
	now=1,k=62;
	while (k--)
	{
		for (int i=now;i<=n;i++)
			if (a[i]&(1LL<<k))
			{
				swap(a[i],a[now]);
				for (int j=1;j<=n;j++)
					if (j!=now&&(a[j]&(1LL<<k))) a[j]^=a[now];
				now++;
				break;
			}
	}
	now--;
}
LL Calc(LL k)
{
	LL ans;
	ans=0LL;
	if (now<n)
	{
		if (k==1) return 0;
		k--;
	}
	if (k>=(1LL<<now)) return -1;
	for (int i=now;k;i--,k>>=1)
	{
		if (k&1LL)
			ans^=a[i];
	}
	return ans;
}
int main()
{
	scanf("%d",&T);
	for (int t=1;t<=T;t++)
	{
		scanf("%d",&n);
		for (int i=1;i<=n;i++)
			scanf("%lld",&a[i]);
		Gauss();
		printf("Case #%d:\n",t);
		scanf("%d",&m);
		while (m--)
		{
			LL x;
			scanf("%lld",&x);
			printf("%lld\n",Calc(x));
		}
	}
	return 0;
}


感悟:

对xor理解的一道好题!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值