HDU 3949 XOR (线性基求第k小异或和)

传送门

Problem Description

XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 234=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.

Input

First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,…KQ.

Output

For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.

Sample Input

2
2
1 2
4
1 2 3 4
3
1 2 3
5
1 2 3 4 5

Sample Output

Case #1:
1
2
3
-1
Case #2:
0
1
2
3
-1

对于这种求几个数异或起来能够得到的最小的值,首先应该将我们的线性基构造成一个特殊的线性基,对于线性基中的每一个元素,尽量让他只

有自己的最高为为1,其他的都改为0就比如10000和10,这样我们就能够通过将k转换成二进制来找到第k小的值。

AC代码如下:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
//#define cout<<"====="<<x<<"====="<<endl; DEBUG(x)
#define DEBUG() cout<<"================="<<endl;
ll a[100],b[100],cnt;
inline void add(ll x) {
	for(int i=62; i>=0; i--) {
		if(x&(1ll<<i)) {
			if(a[i])	x^=a[i];
			else {               //构造线性基
				for(int j=0; j<i; j++)if(x>>j&1)x^=a[j];    //x本来是要插入到i的位置,故用x前面的元素来消除x二进制前面的1
				for(int j=i+1; j<=62; j++)if(a[j]>>i&1)a[j]^=x; //用x来消除x后面的元素在x二进制最高位的1.
				a[i]=x;
				cnt++;
				break;
			}
		}
	}
}
int main() {
	int n,m,kas=0;
	ll x,k;
	int t;
	scanf("%d",&t);
	while(t--) {
		cnt=0;
		memset(a,0, sizeof a);
		memset(b,0,sizeof b);
		int num=0;
		printf("Case #%d:\n", ++kas);
		scanf("%d",&n);
		for(int i=0; i<n; i++) {
			scanf("%lld",&x);
			add(x);
		}
		for(int i=0; i<=62; i++)if(a[i])b[num++]=a[i];  //将线性基换一个数组来存,这样可以保证连续。
		scanf("%d",&m);
		while(m--) {
			ll ans=0;
			scanf("%lld",&k);
			if(cnt<n)k--;      //当cnt小于n说明有元素未被插入,即插入那个元素会异或出0,故k--
			if(k>(1ll<<cnt)-1) {  //线性基能够异或出来的值就是1<<cnt-1,如果k超出这个范围就输出-1。
				puts("-1");
				continue;
			}
			for(int i=0; i<num; i++) {
				if(k&(1ll<<i))	ans^=b[i];   //关于这一步就是k二进制第i位为1就异或b[i]
			}
			printf("%lld\n",ans);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值