A+B Format (20)

12 篇文章 0 订阅
5 篇文章 0 订阅

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
题意理解:

本题实质就是按英文习惯输出两个数的和


我是先把两个数的和转化为字符串,然后倒着把每个元素依次放到链表里,每读到三位加一个‘,’,最后输出链表各元素

#include<iostream> 
#include<string>
#include<list> 
using namespace std;
list<char>l;
int main()  
{  
  int sa,sb,k=1,sum;
  cin>>sa>>sb;
  sum=sa+sb;
  string s=to_string(sum);
    for(int i=s.size()-1;i>=0;i--)
    {
      l.push_front(s[i]);
      if((k++)%3==0&&i!=0&&s[i-1]!='-')
        l.push_front(',');
    }
    for(list<char>::iterator i=l.begin();i!=l.end();i++)  
      cout<<*i;  
    return 0;  
}  

当然还有一种更简单的方法,按照不同数字大小,每次直接读三位

#include<stdio.h>  
int main()  
{  
  int a,b;  
  int sum;  
  while(scanf("%d%d\n",&a,&b) != EOF){  
        sum = a+b;  
    if(sum < 0){  
    printf("-");  
    sum = -sum;  
    }  //注意负转正
    if(sum>=1000000){  
        printf("%d,%03d,%03d\n",sum/1000000, (sum/1000)%1000, sum%1000);  
    }  
    else if(sum >= 1000){  
        printf("%d,%03d\n",sum/1000,sum%1000);  
    } else{  
        printf("%d\n", sum);  
    }  
  }  
  return 0;  
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值