To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A 310101 98 85 88 90 310102 70 95 88 84 310103 82 87 94 88 310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output "N/A".
Sample Input5 6 310101 98 85 88 310102 70 95 88 310103 82 87 94 310104 91 91 91 310105 85 90 90 310101 310102 310103 310104 310105 999999Sample Output
1 C 1 M 1 E 1 A 3 A N/A题意:
给定一个学生成绩表,然后输入查询学生最好的排名,若有多个排名相同,按照A>C>M>E优先级输出
例如给定学生表
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
然后查询310101
310101学生C的排名是第1,M的排名是第4,E的排名是第2,A的排名是第2,最好排名是第1,科目是C
所以输出1 C
输入:
输入学生数N,查询数M
先输入N个学生表
再输入M个查询名单
输出:
分别输出学生最好排名,和最好排名科目
若学生不存在输出“N/A”
方法:
用关联容器map<string,vector<int>> Rank,用来盛学生表,然后输入一个学生,找到该学生最好的排名和最好排名的科目并输出
#include<iostream>
#include<map>
#include<vector>
using namespace std;
map<string,vector<int>> Rank;
map<string,vector<int>>::iterator mapiter;
char out[4]={'C','M','E','A'};//科目代号表
int main(){
string input;
int N,M,tmp,sum=0;
cin>>N>>M;
for(int i=0;i<N;i++)//1输入学生表
{
cin>>input;
for(int i=0;i<3;i++)
{
cin>>tmp;
Rank[input].push_back(tmp);
sum+=tmp;
}
Rank[input].push_back(sum/3);
sum=0;
}
for(int i=0;i<M;i++)//查询
{
cin>>input;
if(!Rank.count(input))//如果学生不在表里
cout<<"N/A"<<endl;
else
{
int besti=3,j=1,bestrank;//besti用来记录学生最好排名的科目代号,bestrank记录最佳排名,j是记录排名的中间变量
for(mapiter=Rank.begin();mapiter!=Rank.end();mapiter++)//先找到每个学生平均成绩排名
if(mapiter->second[3]>Rank[input][3])
j++;
bestrank=j;//考虑到优先级初始化最优排名是平均成绩的排名
j=1;//注意将j置1
for(int i=0;i<3;i++)//分别统计C,M,E的排名,找到最好排名
{
for(mapiter=Rank.begin();mapiter!=Rank.end();mapiter++)
if(mapiter->second[i]>Rank[input][i])
j++;
if(j<bestrank)
{
bestrank=j;
besti=i;
}
j=1;
}
cout<<bestrank<<" "<<out[besti]<<endl;
}
}
return 0;
}