Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
此题我用链表建树,具体过程,用上边的例子来说,一开始根节点肯定是后序遍历的最后一个点,然后在中序中找到根节点位置,然后根节点左边就是根节点的左子树,右边就是根节点的右子树,左右子树构造方法与前面相同

#include<iostream>
#include<string>
#include<queue>
using namespace std;  
int post[31],inorder[31];
typedef struct Treenode
{
	int data;
	Treenode* left,*right;
}Tn;
Tn* buildtree(int pl,int pr,int il,int ir)//pl为前序遍历左端,pr为后序遍历右端,il为中序遍历左端,ir为中序遍历右端
{
	if(pl>pr)
		return NULL;
	int p=il;
	Tn *tn=new Tn; 
	while(inorder[p]!=post[pr])//在中序序列中找到根的位置
		++p;
	tn->data=post[pr];
	tn->left=buildtree(pl,pr-ir+p-1,il,p-1);//构造左子树
	tn->right=buildtree(pr-ir+p,pr-1,p+1,ir); //构造右子树
	return tn;
}
void level_order(Tn* root)
{
	queue<Tn*> Tree;
	Tn *tmp=NULL;
	int flag=1;
	Tree.push(root);
	while(!Tree.empty())
	{
		tmp=Tree.front();
		Tree.pop();
		if(!tmp)
			continue;
		if(flag)
		{
			cout<<tmp->data;	
			flag=0;
		}
		else
			cout<<" "<<tmp->data;
		Tree.push(tmp->left);
		Tree.push(tmp->right);
	}
}
int main(){
	int n;
	Tn*root;
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>post[i]; 
	for(int i=0;i<n;i++)
		cin>>inorder[i];
	root=buildtree(0,n-1,0,n-1);
	level_order(root);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值