1025. PAT Ranking (25)

12 篇文章 0 订阅
8 篇文章 0 订阅

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

上代码

#include<iostream>  
#include<algorithm>  
using namespace std;   
struct stu  
{  
    string no;//登录名  
    int score;//分数  
    int fr,ln,lr;//分别为 final_rank  location_number  local_rank 
}s[30005];  
int cmp(stu a,stu b)//sort所用的cmp函数,按照名次的升序(分数的降序),如果名次相同就按登录名的升序,具体写法见我的博客,sort函数,qsort函数用法  
{  
    if(a.score!=b.score)  
        return a.score>b.score?1:0;  
    else  
        return a.no<b.no?1:0;   
}  
void note(int start,int end,int flag)//note用来给学生标记名词,flag是功能选项,0为分组排名,1为最后排名  
{  
    sort(s+start,s+end,cmp);  
    flag==0?s[start].lr=1:s[start].fr=1;  
    for(int i=1;i<end-start;i++)//给学生依次标记名词  
        if(s[start+i].score==s[start+i-1].score)  
            flag==0?s[start+i].lr=s[start+i-1].lr:s[start+i].fr=s[start+i-1].fr;  
        else  
            flag==0?s[start+i].lr=i+1:s[start+i].fr=i+1;  
}  
int main(){  
    int n,m,k=0;  
    cin>>n;  
    for(int i=1;i<=n;i++)  
    {  
        cin>>m;  
        for(int j=0;j<m;j++)  
        {  
            cin>>s[k].no>>s[k].score;  
            s[k++].ln=i;  
        }  
        note(k-m,k,0);//标记分组排名  
    }  
    note(0,k,1);//标记最后排名  
    cout<<k<<endl;  
    for(int i=0;i<k;i++)  
        cout<<s[i].no<<" "<<s[i].fr<<" "<<s[i].ln<<" "<<s[i].lr<<endl;  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值