PAT 1001 A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include <iostream>
#include <vector>
using namespace std;
int main(){
	int a,b,c,ans=0;
	cin>>a>>b;
	c=a+b;
	if(c<0){
		ans=1;
		c=-c;
	}
	vector<int>v;
	if(c==0)
		v.push_back(0);
	while(c!=0){
		v.push_back(c%10);
		c/=10;	
	}
	vector<int>::reverse_iterator iter;
	if(ans){
		cout<<"-";
	}
	int j=v.size()%3;
	int jj=0;
	for(iter=v.rbegin(); iter<v.rend(); ++iter){  //将结果倒序遍历, 
		cout<<*iter; 
		++jj;
		if(jj==j && j<v.size() || jj%3==j && jj<v.size()){  //在特定位置输出‘,’ 
			cout<<",";
		}
	}
	return 0;
}

Python3  代码如下: 

a , b = input().split(' ')
s = int(a) + int(b)
if s < 0:
    s1=str(-s)
    print('-',end='')
else:
    s1=str(s)
for i in range(1,len(s1) + 1):
    print(s1[i-1] ,',' if i%3==len(s1)%3 and i!=len(s1) else '', sep='', end='')

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值