Pat1001 A+B Format

计划想考个PAT,考虑到自己C++基本功不熟,就在这儿做一些笔记以方便我后面过来看看:

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

题目思路:
两个数字相加得到的结果字符串化,然后每隔三个插个逗号,但是要防止在负号后面插逗号

#include <iostream>

using namespace std;

int main(){
	
    int a, b;
    string sumStr, ans;
    
    cin >> a >> b;
    //to do
    sumStr = to_string(a + b);
    for(int i = 0; i < sumStr.size(); i++){
        char n = sumStr[sumStr.size() - 1 - i];
        if(i % 3 == 0 && i >= 3 && n != '-'){
            ans += ',';
        }
        ans += n;
    }
    for(int i = 0;i < ans.size(); i++){
        cout << ans[ans.size() - 1 - i];
    }
    
    return 0;
}

但其实这儿的代码还是有待改进的:
进行了一定量的优化了之后

#include <iostream>

using namespace std;

int main(){
    int a, b;
    string sumStr, ans;
    
    cin >> a >> b;
    //to do
    sumStr = to_string(a + b);
    for(int i = sumStr.size() - 1,j = 0; i >= 0 ; i--){    //从后往前处理字符并在循环中拼接上去,减少一层循环
        ans = sumStr[i] + ans;
        ++j;
        if(j % 3 == 0 && i && sumStr[i - 1] != '-'){       //此处可以直接用i=0的情况来避免在头部添加逗号的情况
            ans = ',' + ans;
        }
    }
    cout << ans << endl;
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值