1033 To Fill or Not to Fill (25 分)测试点0、1

1033 To Fill or Not to Fill (25 分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: C
max

(≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D
avg

(≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P
i

, the unit gas price, and D
i

(≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
结尾无空行
Sample Output 1:
749.17
结尾无空行
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

代码如下:

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<iostream>


using namespace std;

const int max_n = 100006;
const int INF = 1000006;

struct station
{
	double price;
	double distance;
}sta[506];


bool cmp(station a, station b)
{
	return a.distance < b.distance;
}

int main()
{
	double cmax, d, davg;
	int n;
	scanf("%lf %lf %lf %d", &cmax, &d, &davg, &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%lf %lf", &sta[i].price, &sta[i].distance);
	}
	sta[n].price = 0;
	sta[n].distance = d;
	sort(sta, sta + n, cmp);
	if (sta[0].distance!=0)
	{
		printf("The maximum travel distance = 0.00");
		return 0;
	}
	int curindex = 0;
	double curtank = 0;
	double allmoney = 0;
	double maxdistance = cmax * davg;
	while (curindex < n)
	{
		int nextindex = -1;//下一个能到的最便宜的加油站的下标
		double minprice = 1000000;
		for (int i = curindex + 1; i <= n; i++)
		{
			if (sta[curindex].distance + maxdistance >= sta[i].distance)
			{
				if (sta[i].price <= minprice)
				{
					minprice = sta[i].price;
					nextindex = i;
					if (minprice <= sta[curindex].price)
					{
						break;
					}
				}
			}
			else
			{
				break;
			}
		}
		if (nextindex == -1)
		{
			printf("The maximum travel distance = %.2lf", sta[curindex].distance + maxdistance);
			return 0;
		}
		else
		{
			if (sta[nextindex].price <= sta[curindex].price)
			{
				allmoney += ((sta[nextindex].distance - sta[curindex].distance) / davg - curtank) * sta[curindex].price;
				curindex = nextindex;
				curtank = 0;
			}
			else
			{
				allmoney += (cmax - curtank) * sta[curindex].price;
				curtank = cmax - ((sta[nextindex].distance - sta[curindex].distance) / davg);
				curindex = nextindex;
			}

		}
	}
	printf("%.2lf", allmoney);
	return 0;
}

总结

Cmax、D、Davg都有可能不是整数,所以必须要设置为double型。而且设置成int型(我一开始犯的错误),会导致精度损失,从而答案不正确。测试点1的问题是,如果刚开始出发时最近的加油站距离不是0的话,会无法出发(初始油箱是空的),应该特判这种情况。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值