问题 C: 二叉树遍历

题目链接http://codeup.cn/problem.php?cid=100000611&pid=2

题目描述
二叉树的前序、中序、后序遍历的定义:
前序遍历:对任一子树,先访问跟,然后遍历其左子树,最后遍历其右子树;
中序遍历:对任一子树,先遍历其左子树,然后访问根,最后遍历其右子树;
后序遍历:对任一子树,先遍历其左子树,然后遍历其右子树,最后访问根。
给定一棵二叉树的前序遍历和中序遍历,求其后序遍历(提示:给定前序遍历与中序遍历能够唯一确定后序遍历)。

输入
两个字符串,其长度n均小于等于26。
第一行为前序遍历,第二行为中序遍历。
二叉树中的结点名称以大写字母表示:A,B,C…最多26个结点。

输出
输入样例可能有多组,对于每组测试样例,
输出一行,为后序遍历的字符串。

样例输入
ABC
CBA
ABCDEFG
DCBAEFG

样例输出
CBA
DCBGFEA

代码

#include <iostream>
#include <queue>
#include <algorithm>
#include <string>
using namespace std;

struct node {
	char data;
	node* lchild;
	node* rchild;
};

string pre, in;

node* create(int prel, int prer, int inl, int inr) {
	if(prel > prer)
		return NULL;
	node* root = new node;
	root->data = pre[prel];
	int k;
	for(k = inl; k <= inr; k++)
		if(in[k] == pre[prel])
			break;
	int numl = k - inl;
	root->lchild = create(prel + 1, prel + numl, inl, k  - 1);
	root->rchild = create(prel + numl + 1, prer, k + 1, inr);
	return root;
}

void postorder(node* root) {
	if(root == NULL)
		return;
	postorder(root->lchild);
	postorder(root->rchild);
	cout<<root->data;
}

int main() {
	while(cin>>pre) {
		cin>>in;
		node* root = create(0, pre.size() - 1, 0, in.size() - 1); 
		postorder(root);
		cout<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值