PAT A1088 Rational Arithmetic (20分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805378443755520

题目描述
For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

输入
Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

输出
For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

样例输入
2/3 -4/2

样例输出
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

代码

#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

struct fraction {
	ll up, down;
};

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a % b);
}


fraction reduction(fraction result) {
	if(result.down < 0) {
		result.up = -result.up;
		result.down = -result.down;
	}
	if(result.up == 0)
		result.down = 1;
	else {
		int d = gcd(abs(result.up), abs(result.down));
		result.up /= d;
		result.down /= d;
	}
	return result;
}

fraction add (fraction f1, fraction f2) {
	fraction result;
	result.up = f1.up * f2.down + f2.up * f1.down;
	result.down = f1.down * f2.down;
	return reduction(result);
}

fraction minu (fraction f1, fraction f2) {
	fraction result;
	result.up = f1.up * f2.down - f2.up * f1.down;
	result.down = f1.down * f2.down;
	return reduction(result);
}

fraction multi (fraction f1, fraction f2) {
	fraction result;
	result.up = f1.up *  f2.up;
	result.down = f1.down * f2.down;
	return reduction(result);
}

fraction divide (fraction f1, fraction f2) {
	fraction result;
	result.up = f1.up * f2.down;
	result.down = f1.down * f2.up;
	return reduction(result);
}

void showResult(fraction r) {
	r = reduction(r);	
	if(r.up < 0)
		printf("(");				
    if(abs(r.up) % r.down == 0)			
		printf("%lld", r.up /  r.down);
	else if(abs(r.up) > r.down)
		printf("%lld %lld/%lld", r.up / r.down, abs(r.up) % r.down, r.down);
	else
		printf("%lld/%lld", r.up, r.down);
	if(r.up < 0)
		printf(")");
}

int main() {
	fraction a, b;
	scanf("%lld/%lld %lld/%lld", &a.up, &a.down, &b.up, &b.down);

	showResult(a);
	printf(" + ");
	showResult(b);
	printf(" = ");
	showResult(add(a, b));
	printf("\n");

	showResult(a);
	printf(" - ");
	showResult(b);
	printf(" = ");
	showResult(minu(a, b));
	printf("\n");

	showResult(a);
	printf(" * ");
	showResult(b);
	printf(" = ");
	showResult(multi(a, b));
	printf("\n");

	showResult(a);
	printf(" / ");
	showResult(b);
	printf(" = ");
	if(b.up == 0)
		printf("Inf");
	else
		showResult(divide(a, b));
	printf("\n");
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值