hdu 1003 Max Sum

题目

		Max Sum - 1003
		
		http://acm.hdu.edu.cn/showproblem.php?pid=1003

英文题目

Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

中文翻译

问题描述
给定序列a [1],a [2],a [3] … a [n],您的工作是计算子序列的最大和。例如,给定(6,-1,5,4,-7),此序列的最大和为6 +(-1)+ 5 + 4 = 14。

输入
输入的第一行包含一个整数T(1 <= T <= 20),它表示测试用例的数量。然后是T行,每行以数字N(1 <= N <= 100000)开头,然后是N个整数(所有整数都在-1000和1000之间)。

输出
对于每个测试用例,您应该输出两行。第一行是“ Case#:”,#表示测试用例的编号。第二行包含三个整数,即序列中的最大和,子序列的开始位置,子序列的结束位置。如果有多个结果,请输出第一个。在两种情况之间输出空白行。

样本输入
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

样本输出
Case 1:
14 1 4

Case 2:
7 1 6

解答

Java

import java.util.*;
public class Main {
    public static void main(String[] args) {
        Scanner kb=new Scanner(System.in);
        while(kb.hasNext()) {
            int t=kb.nextInt();
            for(int i=1;i<=t;i++) {
                int n=kb.nextInt();
                int []a=new int[n+1];
                for(int j=1;j<=n;j++) {
                    a[j]=kb.nextInt();
                }
                int max=-1000,sum=0,x=0,y=0;
                for(int j=1;j<=n;j++) {
                    sum+=a[j];
                    if(sum>max) {
                        max=sum;
                        y=j;
                    }
                    if(sum<0)
                        sum=0;
                }
                sum=0;
                for(int j=y;j>0;j--) {
                    sum+=a[j];
                    if(sum==max) {
                        x=j;
                    }
                }
                System.out.println("Case"+" "+i+":");
                System.out.println(max+" "+x+" "+y);
                if(i!=t)
                    System.out.println();
            }
        }
    }
}

C++/C

#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
	int t,n,k=1;
	scanf("%d",&t);
	while(k<=t)
	{
		scanf("%d",&n);
		int a[100001],max=-1000,start=0,end=0,i,sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
			if(sum>max)
			{
				max=sum;
				end=i;
			}
			if(sum<0)
				sum=0;
		}
		sum=0;
		for(i=end;i>0;i--)
		{
			sum+=a[i];
			if(sum==max)
				start=i;
		}
		printf("Case %d:\n",k);
		printf("%d %d %d\n",max,start,end);
		if(k!=t)
			printf("\n");
		k++;
	}
	return 0;
}
				
			
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值