hdu 1002 A + B Problem II

题目

		A + B Problem II - 1002
		
		http://acm.hdu.edu.cn/showproblem.php?pid=1002

英文题目

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

中文翻译

问题描述
对您来说,我有一个非常简单的问题。给定两个整数A和B,您的工作是计算A + B的总和。

输入
输入的第一行包含一个整数T(1 <= T <= 20),它表示测试用例的数量。然后是T行,每行由两个正整数A和B组成。请注意,整数非常大,这意味着您不应使用32位整数来处理它们。您可以假设每个整数的长度不超过1000。

输出
对于每个测试用例,您应该输出两行。第一行是“ Case#:”,#表示测试用例的编号。第二行是等式“ A + B = Sum”,Sum表示A + B的结果。请注意,该等式中有一些空格。在两个测试用例之间输出空白行。

样本输入
2
1 2
112233445566778899 998877665544332211

样本输出
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

解答

java存在大数库,而C/C++中没有,利用数组进行处理。

Java

import java.math.BigInteger;
import java.util.*;
public class Main {
    public static void main(String[] args) {
        Scanner kb=new Scanner(System.in);
        while(kb.hasNext()) {
            int t=kb.nextInt();
            for(int i=1;i<=t;i++) {
                BigInteger a=kb.nextBigInteger();
                BigInteger b=kb.nextBigInteger();
                BigInteger sum=a.add(b);
                System.out.println("Case "+i+":");
                System.out.println(a+" + "+b+" = "+sum);
                if(i!=t)
                System.out.println();
            }
        }
    }
}

C++/C

#include <iostream>
#include <stdio.h> 
#include <string.h>
using namespace std;
int main()
{
	int t,k,i;
	k=1;
	cin>>t;
	while(t--)
	{
		char a[1000],b[1000],c[1000],d[1000];
		cin>>a>>b;
		int len1,len2,lent;
		len1=strlen(a);
		len2=strlen(b);
		if(len1>len2)
		{
			strcpy(c,a);
			strcpy(d,b);
		}
		else
		{
			strcpy(c,b);
			strcpy(d,a);
			lent=len2;
			len2=len1;
			len1=lent;
		}
		for(i=0;i<len2;i++)
		{
			c[len1-i-1]=c[len1-i-1]+d[len2-1-i]-'0';
			if(c[len1-i-1]>'9')
			{
				c[len1-i-1]-=10;
				c[len1-i-2]++;
			}
		}
		for(i=0;i<len1;i++)
		{
			if(c[len1-i-1]>'9')
			{
				c[len1-i-1]-=10;
				c[len1-i-2]++;
			}
		}
		int t0=0;
		d[len1+1]='\0';
		d[0]='1';
		for(i=0;i<len1;i++)
		{
			if(c[i]=='0')
				t0++;
			d[i+1]=c[i];
		}
		if(t0==len1)
			strcpy(c,d);
		printf("Case %d:\n",k++);
		printf("%s + %s = %s\n",a,b,c);
		if(t!=0)
			printf("\n");
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值